ICW Is Unable to Run Due to a Disconnected Network Adapter Error (291862)



The information in this article applies to:

  • Microsoft Small Business Server 2000
  • Microsoft BackOffice Server 2000

This article was previously published under Q291862

SYMPTOMS

When you run the Internet Connection Wizard (ICW) you may receive the following error message:
Disconnected Network Adapter
An unconnected network adapter has been detected. Before continuing, close the wizard, connect or disable the network adapter, and then restart the wizard.

CAUSE

This problem may occur if your server has a Routing and Remote Access interface with an IP address of 169.254.x.y where x and Y represent values between 0 and 255. The interface of the Routing and Remote Access server may have a 169.254.x.y address if:
  1. You configured Routing and Remote Access to use DHCP to assign addresses.
  2. The DHCP server is unavailable.
  3. A remote access client connects to the Routing and Remote Access server which causes the latter to assign an Automatic Private IP Address to itself.
Note: An Automatic Private IP Address is also referred to as an APIPA, Autonet address, IP Address range 169.254.x.y.

For additional information about the RRAS server's use of an Autonet address, click the article number below to view the article in the Microsoft Knowledge Base:

216805 RAS Server Behavior When Configured to Use DHCP

WORKAROUND

To work around this problem, see if the server has a Routing and Remote Access interface with an IP address of 169.254.x.y. To do so, run the ipconfig command from a command prompt to run the Ipconfig command-line utility.

The Ipconfig utility displays the IP configuration information for the network adapters. Look for the IP address in the line "PPP adapter RAS Server (Dial In) Interface." If it does have an IP address of 169.254.x.y, and if no one is currently connected to the Routing and Remote Access server by using a remote access dial-up networking connection, or a virtual private network (VPN) connection to the server, stop the Routing and Remote Access service to run the ICW. If there is a user that is currently connected to the Routing and Remote Access server, wait to run the ICW until the user disconnects the current connection.

To stop Routing and Remote Access to run the ICW:
  1. Click Start, click Programs, click Administrative Tools, and then click Services.
  2. Right-click Routing and Remote Access, and then click Stop.
  3. After the Routing and Remote Access service stops, attempt to run the ICW again.
At this point, you may want to determine why the Routing and Remote Access server was unable to obtain an IP address from the DHCP server.

To start Routing and Remote Access:
  1. Click Start, click Programs, click Administrative Tools, and then click Services.
  2. Right-click Routing and Remote Access, and then click Start.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:1/25/2006
Keywords:kbbug kberrmsg kbfix kbHardware kbnetwork KB291862