You receive an "Internal Error 2318" or an "Error 1326" error message when you try to install the Office 2000 SR-1 Update (291846)



The information in this article applies to:

  • Microsoft Office 2000 (Setup) Service Release 1 (SR-1)

This article was previously published under Q291846
WARNING:This information is preliminary and has not been confirmed or tested by Microsoft. Use only with discretion.

SYMPTOMS

When you run the Microsoft Office 2000 SR-1 Update, you may receive one of the following error messages:
Internal Error 2318: Please contact product support for assistance.
-or-
Error 1326. Error getting file security: SQLSOLDB.HLP GetLastError: 2
If you create a verbose log file for the 2318 error, you find text similar to the following:
MSI (c) (D9:85): Note: 1: 2318 2: c:\Program Files\Common Files\System\Ado\ADO210.CHM 
Internal Error 2318: Please contact product support for assistance.
Action ended 22:03:05: InstallExecute. Return value 3.
				
If you create a verbose log file for the 1326 error, you find text similar to the following:
PatchApply(PatchName=sqlsoldb.hlp,TargetName=C:\WINDOWS\system32\ 
SQLSOLDB.HLP,PatchSize=1285,TargetSize=8292,PerTick=0,IsCompressed=1,
FileAttributes=8192,PatchAttributes=0)
PatchFiles: File: C:\WINDOWS\system32\SQLSOLDB.HLP,  Directory: 
C:\WINDOWS\system32\,  Size: 
MSI (s) (A4:8C): Note: 1: 1326 2: 2 3: SQLSOLDB.HLP
Error 1326. Error getting file security: SQLSOLDB.HLP GetLastError: 2
MSI (s) (A4:8C): Product: Microsoft Office 2000 SR-1 Premium -- Error 1326.
 Error getting file security: SQLSOLDB.HLP GetLastError: 2

Action ended 9:15:16: InstallExecute. Return value 3.
				

CAUSE

These error messages can appear if certain Microsoft Data Access Components (MDAC) Help files are missing or are located in the wrong folder on your hard disk.

RESOLUTION

To resolve this problem, you must re-run the SR-1 Update with verbose logging turned on. To do this, follow these steps:
  1. On the Start menu, click Run.
  2. In the Open box, type the following command line:

    source path\Setup.exe /L2 /V

    where source path is the full path to Setup.exe for the SR-1 Update, according to the following table.
       SR-1 Source                <source path>
       ------------------------------------------------------
    
       You previously attempted
       the SR-1 Update from the
       Office Update download     C:\Windows\Temp\SR1patch\ 
    
       SR-1 Update CD             <CD-ROM drive letter>:\Setup.exe
    						
    This creates the Setup log file and a verbose Windows Installer log file in the \Temp\SR1Patch folder.
    Log file for           Log file name
    ---------------------------------------------------------------
    
    Setup.exe              Office 2000 SR-1 Setup(####).txt
    Windows Installer      Office 2000 SR-1 Setup(####)_MsiExec.txt
    					
    The #### characters in the log file names are numbers that begin with 0001. They increment by 1 if you run the update multiple times. So the log file with the highest number is the log file for the last time that you ran the update.

    NOTE: If you do not see the text "VERBOSE" in the first line of text of the "Office 2000 SR-1 Setup(####)_MsiExec.txt" file, you did not create the verbose log file correctly, and you must repeat the preceding command line with the correct command-line switches.

  3. Open the Windows Installer log file by using WordPad, and search for Return value 3.
  4. Back up a few lines in the log file to the line that contains the file that the update is having problems patching.

    For the 2318 error, it is similar to the following:
    MSI (c) (8B:87): Note: 1: 2318 2: C:\Program Files\Common Files\System\Ado\ADO210.CHM
    						
    For the 1326 error, it is similar to the following:
    PatchFiles: File: C:\WINDOWS\system32\SQLSOLDB.HLP,  Directory: C:\WINDOWS\system32\,  Size:
    						
    This line identifies the problematic file and its correct location on your hard disk.
  5. If the file listed on this line of the log file is listed in the table in step 6, continue with the steps in this article. If the file is not listed in the table, please contact Microsoft Product Support Services.
  6. Copy the files listed in the following table from your Office 2000 CD into the specified folder location on your hard disk.
    File name     Office 2000 CD1 location     Hard disk location
    ---------------------------------------------------------------------------
    Ado210.chm    Pfiles\Common\System\Ado     Program Files\Common Files\ 
                                                  System\ADO
    
    Dao360.chm    Pfiles\Common\Msshared\Dao   Program Files\Common Files\ 
                                                  Microsoft Shared\DAO
    
    Jetdef40.chm  Pfiles\Msoffice\Office\1033  Program Files\Microsoft Office\ 
                                                  Office\1033
    
    Jetsql40.chm  Pfiles\Msoffice\Office\1033  Program Files\Microsoft Office\ 
                                                  Office\1033
    
    Msjro.chm     Pfiles\Common\System\Ado     Program Files\Common Files\ 
                                                  System\ADO
    
    Sqlsoldb.hlp  \System                      See NOTE below. 
    						
    NOTE: If the problematic file is Sqlsoldb.hlp, identify the correct hard disk location for this file from the log file line in step 4. Then copy Sqlsoldb.hlp from the \System folder on the Office 2000 CD to the hard disk location listed in step 4.
  7. Re-run the SR-1 Update with verbose logging enabled. If you encounter another 2318 or 1326 error message, reapply steps 3 through 6 for the latest problem file listed in the log file.

Modification Type:MinorLast Reviewed:9/14/2004
Keywords:kbtshoot kbstartprogram kbsetup kberrmsg kbprb KB291846