Analysis Database Wizard Fails to Connect When You Install MDAC 2.6 (290568)



The information in this article applies to:

  • Microsoft Site Server 3.0 Commerce Edition
  • Microsoft Site Server 3.0

This article was previously published under Q290568

SYMPTOMS

When you install Microsoft Data Access Component (MDAC) version 2.6 on a computer running Site Server Analysis, and then run the Database Setup Wizard (for Microsoft SQL Server), the following error message occurs when you try to connect to a SQL Server 7.0 or SQL Server 2000 database:

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Microsoft Site Server Analysis
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Please check your login settings. Couldn't connect to: ssa
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OK
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CAUSE

An MDAC connectivity issue that involves Site Server 3.0 Analysis causes this problem.

WORKAROUND

To work around this problem, use an earlier version of MDAC. For more information on the current installation order for Site Server, see the following:

RESOLUTION

To resolve this problem, remove "DBSetup" from the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\Client\ODBCAppCompat

This allows MDAC versions 2.6 and 2.7 to operate successfully with Usage Analysis.

NOTE: This configuration requires SQL Server version 7.0 or SQL Server version 2000; SQL Server version 6.5 does not operate in this configuration.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

If you install SQL Server 2000 on the same system as Site Server 3.0, MDAC updates to version 2.6 by default. Therefore, you cannot connect to a remote SQL Server 7.0 database. However, in this scenario, you should be able to connect to a remote SQL Server 2000 database.

Modification Type:MajorLast Reviewed:5/15/2006
Keywords:kbbug kbfix KB290568