0203 Error Message Occurs When You Start the Windows Installer Service (288903)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition SP4
  • Microsoft Windows NT Server 4.0 Terminal Server Edition SP5
  • Microsoft Windows NT Server 4.0 Terminal Server Edition SP6
  • Microsoft Windows NT Workstation 4.0 SP3
  • Microsoft Windows NT Workstation 4.0 SP4
  • Microsoft Windows NT Workstation 4.0 SP5
  • Microsoft Windows NT Workstation 4.0 SP6
  • Microsoft Windows NT Workstation 4.0 SP6a
  • Microsoft Windows NT Server 4.0 SP3
  • Microsoft Windows NT Server 4.0 SP4
  • Microsoft Windows NT Server 4.0 SP5
  • Microsoft Windows NT Server 4.0 SP6
  • Microsoft Windows NT Server 4.0 SP6a
  • Microsoft Windows NT Server, Enterprise Edition 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP4
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP5
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP6
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP6a

This article was previously published under Q288903

SYMPTOMS

When you attempt to start the Windows Installer service on a Windows NT 4.0-based computer that is installed on an NTFS file system (NTFS) volume, you may receive the following error message:
Could not start the Windows Installer service on Computer Name

Error 0203: The system could not find the environment option that was entered.

CAUSE

This issue can occur if you modify the default access control list (ACL) on the %SystemRoot%\Installer working folder. The Windows Installer service operates under the context of the System security account, and this account must have Full Control permissions to the Installer folder. The default permission for the Installer folder is Full Control for the Everyone group.

RESOLUTION

To resolve this issue, modify the ACL for the %SystemRoot%\Installer folder so that the System account has Full Control permissions:
  1. Start Microsoft Windows NT Explorer from the Start menu.
  2. Right-click the %SystemRoot%\Installer folder and click Properties.
  3. Click the Security tab, and then click Permissions.
  4. Click Add, locate the System account (the operating system), and then click Add.
  5. In the Type of access box, click Full Control, and then click OK.
  6. Verify that the System account is added to the ACL list, click Replace permissions on subdirectories check box, and then click OK.
  7. When you are prompted to replace permissions on all subdirectories, click Yes.
  8. Click OK.

Modification Type:MajorLast Reviewed:5/13/2003
Keywords:kbenv kberrmsg kbprb KB288903