XCON: Recipient Policy Cannot Match the FQDN of Any Server in the Organization, 5.4.8 NDRs (288175)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q288175

SYMPTOMS

Two Exchange 2000 servers located in the same administrative group or routing group cannot send mail to each other. Mail refuses to go through SMTP, and eventually sits in the message transfer agent (MTA) queues to the other server.

This can also appear in an Exchange 2000, Exchange 5.5 mixed mode environment. All Exchange 2000 servers can send mail to each other, but all mail to an Exchange 5.5 server will not deliver and will return the Events and NDRs included in this article.

You also see the following event ID in the program event log:

Source: MSExchangeMTA
Category: Security
Event ID: 9297
Description:
The user /o=Microsoft/ou=First Administrative Group/cn=Configuration/cn=Servers/cn="server_name" has caused a security violation. Locality table (LTAB) index: 4. Windows 2000 error code: 0X80070005. [BASE IL MAIN BASE 1 237] (14)

After applying Service Pack 1 for Exchange 2000, you will instead get this error:
Event Type: Warning
Event Source: MSExchangeTransport
Event Category: Categorizer
Event ID: 9006
User: N/A
Computer: EXCHANGE
Description: The FQDN of a remote server is also configured as a local domain on this SMTP virtual server. This is causing 5.4.8 NDRs. Please remove 'unik.dk' from your recipient policies.
Data: 0000: c0040242
Users will also receive the following NDR:

Your message did not reach some or all of the intended recipients.
Subject: Test Message
Sent: 7/12/2002 5:27 PM
The following recipient(s) could not be reached: Richard Bready on 7/12/2002 5:27 PM. A configuration error in the e-mail system caused the message to bounce between two servers or to be forwarded between two recipients. Contact your administrator. <server1.contoso.com #5.4.8>

CAUSE

A server to which you are trying to send mail has a Fully Qualified Domain Name (FQDN) that matches the domain name in the E-Mail Addresses of a Recipient Policy.

The behavior described in the "Symptoms" section of this article can occur in a mixed mode environment if the NetworkAddress attribute of the Microsoft Exchange 5.5 server matches the domain name in the E-Mail Addresses of a Recipient Policy. The NetworkAddress attribute is created using the Host and Domain Name fields under the TCP/IP Protocol settings.

WORKAROUND

Remove or rename the recipient policy, or rename the server, thereby changing the fully qualified domain name (FQDN) of that server. The following is an example of an FQDN in the recipient policy:

Type:SMTP
Address: ServerName.Domainname.com

Change this in the recipient policy to reflect:

Type:SMTP
Address: DomainName.com

On an Windows NT 4.0 Exchange 5.5 server, the NetworkAddress attribute is created using the Host and Domain Name fields under the TCP/IP Protocol settings. The host name should not be the e-mail address domain name from your recipient policies. Generally, the host name would be the NetBios name of the Windows NT 4.0 computer on which Exchange 5.5 is installed. You can view the NetworkAddress attribute by using the Exchange 5.5 Administrator in Raw Mode.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

MORE INFORMATION

Using the message tracking center, you can view the following information:

1/25/2001 10:37 AM Tracked message history on server "Server_Name"
1/25/2001 10:37 AM SMTP Store Driver: Message Submitted from Store
1/25/2001 10:37 AM SMTP: Message Submitted to Advanced Queuing
1/25/2001 10:37 AM SMTP: Started Message Submission to Advanced Queue
1/25/2001 10:37 AM SMTP: Message Submitted to Categorizer
1/25/2001 10:37 AM SMTP: Message Delivered Locally
1/25/2001 10:37 AM SMTP Store Driver Submitted Message to MTA

For additional information about recipient policies, click the article number below to view the article in the Microsoft Knowledge Base:

263845 XADM: How to Modify Recipient Settings in Exchange System Manager


Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbbug kbpending kbprb KB288175