BUG: IntelliSense Does Not Work for the Users Group in Visual J++ 6.0 (285779)



The information in this article applies to:

  • Microsoft Visual J++ 6.0, when used with:
    • the operating system: Microsoft Windows 2000

This article was previously published under Q285779

SYMPTOMS

If you are logged on as user in the Users group on a Windows 2000-based computer, IntelliSense does not work in Visual J++ 6.0. The Class Outline window does not show superclasses as well.

If you add the user account to the local Administrators group or Power Users group, IntelliSense works in Visual J++ as expected. IntelliSense does work in other Microsoft Visual Studio applications, such as Microsoft Visual C++, Microsoft Visual Basic, and Microsoft Visual InterDev.

CAUSE

Visual J++ uses the Package database registry key to store information about Java classes that are installed on the system. By default, this key points to the home folder of the user who installed Visual J++ on that computer. As a result, only users who are members of the Administrators group have access to this folder.

RESOLUTION

If you do not want to give Power Users group privileges to all Visual J++ users, you can work around this problem as follows:
  1. On the Start menu, click Run, and then type regedt32 to start Registry Editor.
  2. Locate the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Classpath\Classes key. Notice that the value of [Package database] key looks like C:\DOCUME~1\<User1>\LOCALS~1\Temp\cpm1.tmp, where User1 is the name of the user who installed Visual J++.

    In Visual J++, IntelliSense uses the Cpm1.tmp file and cannot access it unless the user has the appropriate permissions on that folder.
  3. In Windows Explorer, browse to the folder from step 2, and set the security permissions to Full Control for all Visual J++ users. To do this, follow these steps:
    1. Right-click the folder, and then click Properties.
    2. In the Properties dialog box, click the Security tab.
    3. In the Name list, click the appropriate user name(s). In the Permissions list, make sure that the Full Control check box is selected.
Note You cannot move the Cpm*.tmp files from this folder to another location to work around this problem.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Steps to Reproduce Behavior

  1. Log on as a user in the Administrators group, and install Visual J++.
  2. Create a new user account in the Users group.
  3. Log on as the new user, and then start Visual J++. IntelliSense does not work.

Modification Type:MajorLast Reviewed:10/20/2003
Keywords:kbBug kbIDEProject kbnofix KB285779