OL2000: (CW) Error Message Occurs When You Send an Encrypted Message to a Recipient on the Global Address List (282959)



The information in this article applies to:

  • Microsoft Outlook 2000
  • Microsoft Outlook 2000, Service Release 1 (SR-1)

This article was previously published under Q282959
NOTE: The procedures in this article only apply if you have installed Outlook with the Corporate or Workgroup option. With this option, you can use Messaging Application Programming Interface (MAPI) services. To determine your installation type, click About Microsoft Outlook on the Help menu. If you have the Corporate or Workgroup installation, you see "Corporate or Workgroup".

SYMPTOMS

When you send an encrypted message to a recipient that is located in the Global Address List, you may receive the following error message:
Encryption Problems

Microsoft Outlook had problems encrypting this message because the following recipients had missing or invalid certificates or conflicting or unsupported encryption capabilities:

User

Continue will encrypt and send the message but the listed recipients may not be able to read it.

CAUSE

This issue can occur because when Outlook searches the Global Address List for encryption certificates, it searches for three properties in the following order:
  1. Tagged-X509certs
  2. X509-certs
  3. User-certs
If the Tagged-X509certs property is invalid (for example, if it is expired, corrupted, and so on), Outlook does not fail over and query for any valid X509-certs or User-certs properties. For example, if the Tagged-X509certs property is missing and the X509-certs property is invalid, Outlook does not fall back and query the User-certs property, even if the property is valid. This behavior prevents the user from sending encrypted mail to other users who have an invalid digital certificate.

WORKAROUND

To prevent this behavior, identify and remove the invalid or expired digital certificate from the Global Address List.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:5/20/2003
Keywords:kbbug kbnofix KB282959