Stop 0x0000001E When You Use User Mode Print Drivers to Print in Terminal Server (282215)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition

This article was previously published under Q282215

SYMPTOMS

When you try to print from a Terminal Server-based client by using a user mode printer driver (Umpd.dll), the Windows NT Server version 4.0, Terminal Server Edition-based server may generate a the following error message on a blue screen:
STOP 0x0000001E (0xc0000005, 0xa3012bb4, 0x00000000, 0x00000004)

CAUSE

This problem can occur because spooler tries to display a dialog box to the client desktop but the desktop handle is not available.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date        Time             Size       File name   Platform
   ------------------------------------------------------------
   07/11/2000  05:45p             170,256  Gdi32.dll   Intel
   07/11/2000  05:44p             331,536  User32.dll  Intel
   11/21/2000  08:47p           1,279,824  Win32k.sys  Intel
   03/01/2001  06:19p             195,856  Winsrv.dll  Intel
				

STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0.

MORE INFORMATION

We have seen a similar problem with HP Design Jet Printers. For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

301330 Stop 0x0000001E Error Message Printing with Hewlett-Packard DesignJet Printer Driver from a Terminal Services Client


Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kbenv kberrmsg kbfix kbprint kbQFE KB282215