OFFXP: "No Virus Scanner Installed" Message Appears in Security Dialog Box (282207)



The information in this article applies to:

  • Microsoft Excel 2002
  • Microsoft PowerPoint 2002
  • Microsoft Word 2002

This article was previously published under Q282207

SYMPTOMS

When you view the Security dialog box from any of the Microsoft Office programs listed at the beginning of this article, you may see the following text:
No virus scanner installed.
This message appears even if you have a third-party virus scanning program installed on your computer.

CAUSE

This message appears because the installed third-party virus scanning program does not support the Anti-Virus API for Office XP.

MORE INFORMATION

Excel, PowerPoint, and Word allow third-party virus scanning programs to check each document before you open it. This helps to ensure that a file does not contain a known virus. When installed, the third-party virus scanning program registers its support of this Anti-virus API. If the third-party virus scanning program does not support this API, you will see the message in the Security dialog box.

If you regularly update the third-party virus scanning program, you can set the security level to Low and avoid all Office security warnings. Because different macro virus strains can appear frequently, you should update your third-party virus scanning program often.

When evaluating a third-party scanning program, consider a program that can detect common Trojan horse attacks. Some third-party virus scanning programs do not protect against such malicious code attacks.

If you set your security level to Low, you may not be protected from new viruses or Trojan horses if the third-party virus scanning program cannot identify it. To better protect against new malicious code, set your security level to Medium or High. If you get a non-signed macro security warning, your third-party virus scanning program has not found any known virus, you know the source of the marco and need to run it, then you can better assess the safety of enabling the macro.

To view the Security dialog box, follow these steps:
  1. Start one of the Office programs listed at the beginning of this article.
  2. On the Tools menu, point to Macro, and then click Security.

Modification Type:MinorLast Reviewed:1/27/2005
Keywords:kbprb KB282207