You receive Application Center MMC error ASP 0177 (281918)



The information in this article applies to:

  • Microsoft Application Center 2000

This article was previously published under Q281918

SYMPTOMS

When you click the Refresh button in Microsoft Management Console (MMC) on the member server, you may receive the following error message:
"An error has occurred. 006~ASP 0177~Server.CreateObject Failed~Invalid ProgID. For additional information specific to this message please visit the Microsoft Online Support site located at: http://search.support.microsoft.com/search/?adv=1. (0x800401F3)"

CAUSE

This behavior may have many causes, such as the following:
  1. A client computer temporarily loses its connection to a domain controller (DC).
  2. The test account on the cluster controller does not have Administrative permissions. This scenario is described in the "Steps to Reproduce the Behavior" section.

RESOLUTION

You can ignore this error message. It will go away.

STATUS

Steps to Reproduce the Behavior

To reproduce the behavior, you must have three computers, two domain user accounts, and a network hub.

NOTE: For this scenario, NAUser is your domain user account. NAtest is another test account for which you have a password. Set up the client computer as a DC (use the cluster computers as members), so that you can run this test on a private network.

Client Computer:
Network: connection direct
Application Center 2000: Not Installed
NAUser: Administrator permissions
NAtest: No permissions

Brick 1:
Network: connection through the hub
Application Center 2000: Installed
NAUser: Administrator permissions
NAtest: Administrator permissions

Brick 2:
Network: connection through the hub
Application Center 2000: Installed
NAUser: No permissions
NAtest: Administrator permissions

  1. Create a cluster on Brick 1.
  2. Add Brick 2 to the cluster.
  3. On the member server, connect only to the member by using the MMC. Verify that the connection works.
  4. On the client computer, connect to the member by using Internet Explorer. When you are prompted for credentials, supply the test account credentials, and then verify that the connection works.
  5. On the hub, turn off the uplink button. This will allow the two bricks to continue to communicate, but will stop access from the network and from the DC.
  6. On the member server, connect only to the member by using MMC. Verify that the connection works.
  7. On the client computer, connect to either of the members by using Internet Explorer. Verify that the connection does not work because the computer cannot be found.
  8. On the hub, turn on the uplink button. This makes the cluster computers visible to the network again.
  9. On the member server, connect only to the member by using MMC. Verify that the connection works.
  10. On the client computer, connect to the member by using Internet Explorer. You receive an error message in Internet Explorer before you receive the prompt for the credentials (there might be a delay of up to 5 minutes after the hub connection is turned on before you receive this error message).
  11. Go back to the member server, and then refresh the pages in MMC. You receive the error message in MMC for several minutes, and then the message goes away.

Modification Type:MajorLast Reviewed:7/17/2006
Keywords:kberrmsg kbprb KB281918