PRB: Dialog Box Opens During Backup Process Prompting You To Insert Disk in Drive A (281345)



The information in this article applies to:

  • Microsoft SQL Server 2000 (all editions)
  • Microsoft SQL Server 6.5
  • Microsoft SQL Server 7.0

This article was previously published under Q281345

SYMPTOMS

When you try to backup a SQL Server database, you may receive the following error message:
There is no disk in the drive. Please insert a disk into drive A:.
This may occur even if you are not backing up to Drive A.

You may also see other similar 'Hard Errors' such as there is no hard disk in the removable disk drive (for example a Zip drive).

CAUSE

When SQL Server starts up, it sets the default error mode handling for the SQL Server process using the SetErrorMode Win32 API. The default error mode setting prevents the popup messages.

If the default error mode setting is changed to allow the popup messages, when a popup occurs, SQL Server has to wait for user input to respond to the popup.

Other components such as OLE DB, COM objects and Extended Stored Procedures can change the default error mode handling for the SQL Server process and cause the popup messages to appear.

WORKAROUND

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry


WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Microsoft recommends that you set the following registry key on production SQL Server computers to avoid the chance of receiving messages:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows\ErrorMode Value = 2

  • The value of 2 instructs the Windows NT operating system to avoid popup messages for any hard error on the system and return the default error condition to the calling process.
  • This registry key is always checked before any hard error is received. Therefore, you do NOT have to restart the system after changing the key value. You can immediately reset the key back to 0 if any unexpected side effects occur.NOTE: No matter what the setting of the registry value, the CSRSS.exe process always logs the message details to the Windows NT Event Log.
If you do not want to set the registry key, use one of the following options:

Click Continue in the dialog box. You may have to click Continue several times before the dialog box disappears. SQL Server then ignores the message and continues.

-or-

Keep a floppy permanently inserted in disk drive A.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The Windows operating system has a limited subset of errors called 'Hard Errors.' These hard error conditions result in you receiving a dialog box on the default desktop.

The default desktop is significant because Windows considers terminal server sessions as alternate desktops. The CRCSS.exe process handles any hard error condition and displays the error on the default computer console (desktop). For example, if you are using a terminal server session to your SQL Server and the dialog box occurs, you would not receive the dialog box because it is sent to the default desktop. Because SQL Server is waiting for user input to the dialog box, SQL server can potentially appear to stop responding if the dialog box is never responded to.

Modification Type:MajorLast Reviewed:11/14/2003
Keywords:kbBug kbpending KB281345