Incorrect Error Message When You Use SubmitSync to a Port with a Service Window Enabled (281170)



The information in this article applies to:

  • Microsoft BizTalk Server 2000

This article was previously published under Q281170

SYMPTOMS

When you use the IInterchange interface SubmitSync method, you may receive the following error message:
An error occurred in BizTalk Server.

Details:
The synchronous submission could not be completed because the channel matched a distribution list containing multiple messaging ports. Only one messaging port is allowed to be attached to the channel.

Code: C0C00161
Source: (null)

CAUSE

This problem occurs when you use the SubmitSync method to process a document through a BizTalk Messaging port that has a Service Window enabled. The error message is by design, but the text of this error message is incorrect and misleading.

WORKAROUND

To work around this problem, do one of the following:
  • Change your code to use Submit instead of SubmitSync.

    -or-

  • Edit the Messaging Port properties to disable the use of the Service Window.

STATUS

Microsoft has confirmed that this is a problem in BizTalk Server 2000.

MORE INFORMATION

The SubmitSync method requires a response from BizTalk Server when it sends an interchange. When a messaging port uses a Service Window, there is no immediate response, so the SubmitSync call fails.

When you use Submit with a port that uses a Service Window, the interchange is sent to the Scheduled queue to wait for the Service Window time to become available.

Modification Type:MajorLast Reviewed:10/22/2003
Keywords:kbbug kbpending KB281170