COM+ and DCOM Errors When Remapping Citrix Drive (280719)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server

This article was previously published under Q280719

SYMPTOMS

When you complete a drive remapping during a Citrix MetaFrame 1.8 installation on a Microsoft Windows 2000 Terminal Server computer, you may find the following event logged in the System Event log:
Event: 10010
Source: DCOM

Description:
The server {02D4B3F1-FD88-11D1-960D-00805FC79235} did not register with DCOM within the required timeout.
You may also find the following event in the Application Event log:
Event: 4097
Source: COM+

Description:
The run-time environment has detected an inconsistency in its internal state. Please contact Microsoft Product Support Services to report this error. Error in .\crmrecoveryclerkobj.cpp(1149), hr = 80070003: GetVolumeInformation.
Additionally, you may not be able to administer COM+ on that computer. You may also be unable to start any COM+ applications. When you try to start a COM+ application, you may receive the following error message:
An error occurred while processing the last operation. Error code 80080005 - Server execution failed.

CAUSE

This problem may occur if you install Citrix MetaFrame 1.8 for Windows 2000 and use the drive remapping feature during the MetaFrame installation.

MORE INFORMATION

When Citrix MetaFrame remaps the system drive, the installation searches the registry to replace all occurrences of the current system drive letter with the new remapped drive letter. However, the system drive information in the COM+ Catalog is not changed. Also, the COM+ system applications path of the Compensating Resource Manager log file (Crm.log) that is used by the COM+ system application is not updated. When a COM+ system application starts, the program tries to read the Crm.log file. Because the system applications path is not updated, the COM+ application cannot find Crm.log and shuts down after displaying an error message. Depending on which additional programs are running on the computer, this can occur several times per minute. This can also make it impossible to administer COM+ on the computer.

RESOLUTION

To resolve this problem, you must remove and reinstall Citrix MetaFrame without drive remapping. For more information about drive mapping with Citrix MetaFrame, visit the following Citrix Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

WORKAROUND

To work around this problem, follow these steps:
  1. Create a new drive partition, and then assign to it the drive letter of the original system drive before Citrix was installed.

    For example Citrix will typically change the C: drive to an M: drive. If you do not have hard drive space available to make the new partition, you may alternatively create a drive mapping to a network share. When mapping the drive, assign to it the same drive letter as the original system drive, drive C: in this example.
  2. After the partition or drive mapping is created, create a \WINNT folder on the new drive.

    Create a \REGISTER subfolder within the \WINNT folder.
  3. Copy the contents of the \REGISTER folder from the Citrix MetaFrame system drive (drive M: in this example) to the drive that you created in step 1.
After you complete these steps, COM+ system applications should start successfully as the applications will be able to locate the Crm.log file.

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:4/18/2003
Keywords:kbprb kbRepair kbWFP w2000wfp KB280719