"No Templates Could Be Found" Error Message While You Enroll for a Smart Card (279781)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Professional SP1

This article was previously published under Q279781

SYMPTOMS

When you are enrolling a user for a smart card certificate at the Certificate Server Web site, you receive the following error message:
Microsoft Internet Explorer

No templates could be found. There are no CAs from which you have permission to request a certificate, or an error occured while accessing the Active Directory.

CAUSE

If there is an Enterprise Certificate Authority (CA) that is published in the Active Directory, the user or the client computer might not trust it.

RESOLUTION

Use the Microsoft Management Console (MMC) snap-in of the Certificate to verify that the CA certificate for Enterprise CA does not exist in either the user's Trusted Root store, or the local computer's Trusted Root store. If it does not, the CA certificate can be downloaded by either of the following two methods:

Method 1

Windows Enterprise Certificate Authorities automatically publish their CA certificates in the Enterprise Trusted Root store. Certificates in the Enterprise Trusted Root store are pushed out to all clients by way of the Security Group Policy. You can refresh the Security policy on the client by using the following command:

secedit /refreshpolicy machine_policy /enforce

Method 1

You can download the CA certificate directly from the CA Web site if you have Internet Information Server installed, by following these steps:
  1. Go to the following Web address

    http://CAServerName/certsrv

    where CAServerName is the CA server name.
  2. Click Retrieve the CA certificate or certificate revocation list, click Next, and then click Install this CA certification path.

Modification Type:MinorLast Reviewed:1/26/2006
Keywords:kbenv kberrmsg kbpending kbprb KB279781