XFOR: Exchange SNADS Connector Shuts Down and a 22096 Event Is Reported (279727)



The information in this article applies to:

  • Microsoft Exchange Server 5.5

This article was previously published under Q279727

SYMPTOMS

The Microsoft Exchange Connector for SNADS may shut down. When you use the Exchange Connectivity Administrator to view the Connectivity Controller log, the following error message may be reported:
2000/09/28 13:19:12-LME-SNADS-MEXDIA(00d4)
4 04103:Queue snads.in depth threshold has reached the maximum number specified. Current 128, Maximum 60
In addition, the following event may be reported in the application event Log in Event Viewer:

Event ID: 22096
Source: MSExchangeSNADS
Category: Transport from SNADS

Queue threshold exceeded. Suspending SNA Link. Please reduce disk usage.

CAUSE

This issue can occur if the queue depth for messages has reached its maximum level. When the Exchange SNADS Connector reaches its threshold for messages, the service is designed to shut down.

RESOLUTION

To resolve the issue, increase the "qdepththreshold" entry in the Exchconn.ini file. This file is located in the Exchsrvr\Connect\Exchconn folder. Modify the section labeled "[QM]".

The following text is an example of the section that you need to edit. Notice that the current "qdepththreshold" entry is set to 500:

[QM]
; baditemthreshold =
; qdepththreshold = 500
; itemagethreshold =
; qspacethreshold =
; qroot =
; quickscan =
; pollinterval =
; version =
; maxhopcount =
; maxretrycount =
; ROUTER parameters.

After you increase this setting, restart the MSExchange Connectivity Controller and the Exchange SNADS Connector for the changes to take effect.

STATUS

This behavior is by design.

MORE INFORMATION

After the Exchange SNADS Connector service quits and the errors are reported, you must manually restart the service.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbprb KB279727