Works: How to Troubleshoot Setup Hanging and Error Messages (279625)



The information in this article applies to:

  • Microsoft Works Suite 2005
  • Microsoft Works Suite 2004
  • Microsoft Works Suite 2003
  • Microsoft Works Suite 2002
  • Microsoft Works Suite 2001
  • Microsoft Works 8.0
  • Microsoft Works 7.0
  • Microsoft Works 6
  • Microsoft Works Suite 2006

This article was previously published under Q279625

SYMPTOMS

When you install one of the products listed at the beginning of this article, you may receive one of the following error messages:
  • Setup.exe is Not a Valid Win32 Application.
  • Setup caused an exception in c0000006h in module filename.
  • <Program> caused an exception in c0000006h in module <filename>.
  • %1 is Not a Valid Win32 Application
  • Unknown has caused an exception in unknown.
  • Setup caused an invalid page fault in module unknown.
When you click Close, your computer may stop responding (hang).

When you install one of the products listed at the beginning of this article, your computer may stop responding (hang).

CAUSE

This behavior can occur if any of the following conditions are true:
  • The installation CD-ROM may be dirty or damaged.
  • A program running in the background may interfere with the installation process.
  • Microsoft Access Data Components (MDAC) may not be installed properly.
  • Microsoft Internet Explorer may be damaged not installed properly.

These errors can also occur because of CD-ROM Read issues.

RESOLUTION

To resolve this issue, use the following methods in the order in which they are presented.

Examine and Clean the CD-ROM

Clean the CD-ROM for the program. To do this, use a CD-ROM cleaning kit, or gently wipe the silver side of the CD-ROM with a soft, lint-free cotton cloth. Do not use paper cloth which can scratch the plastic and leave streaks. When you clean the CD-ROM, wipe from the center of the disc outward. Do not use a circular motion.

If the issue continues to occur, clean the CD-ROM with a damp cloth or a commercial CD cleaning solution. Dry the CD-ROM thoroughly before you insert it into the CD-ROM drive.

If the issue continues to occur, click the following article number to view the article in the Microsoft Knowledge base:

218617 How to Troubleshoot CD-ROM Read Errors

If the issue continues to occur, examine the CD-ROM for any scratches or other damage. If the CD-ROM is scratched or damaged, contact the retailer from whom you purchased the program to arrange an exchange, or call 1-800-360-7561 to request a replacement CD-ROM.

If the issue continues to occur, continue to the next method.

Test the Disc in a Different Drive

If your computer has multiple CD-ROM, CD-R, CD/RW or DVD drives, test the disc in the other drive. For DVDs, make sure the drive bears a DVD logo on the front. If the disc functions in another drive, the original drive may not be properly reading the disc. For help, contact your computer or disc drive manufacturer.

If the disc is clean and does not work in another drive, then the disc is likely damaged and has to be replaced.

Clean the Drive

You can clean the disc drive using a CD-ROM or DVD drive cleaning disc, which are available in most computer or home electronics stores. Before you purchase a drive cleaning disc, try troubleshooting the issue by using the remaining steps in this article.

Test Disc Read with Copy or Xcopy

Copy and Xcopy are command-line utilities that typically uncover a disc read issue. If Copy and Xcopy complete successfully, the issue is not likely to be a problem reading the disc. A failure to copy can indicate drive or system problems and illustrate the need for additional troubleshooting.

To test disc read by using Copy and Xcopy, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open dialog box, type cmd, and then press ENTER.
  3. At the prompt, type one of the following commands: To copy a folder: copy discdrive:\foldernamedrive:\psstest /V

    To copy the whole disk: xcopy discdrive:\*.* drive:\psstest /V /E

    NOTE: discdrive is the drive letter of the CD-ROM or DVD drive, foldername is the name of the folder that contains files that you must have to access on the disk, and drive is the letter of your system hard disk.
  4. Press ENTER.
  5. If prompted "Does psstest specify a file name or directory name?", press F.
  6. If prompted Overwrite ... (Yes/No/All)? press A.

    NOTE: Using /V with Copy or Xcopy verifies the copied files and takes much longer but makes sure that the files were copied correctly.

Clean Boot the Computer

Programs that run in the background can interfere with the installation process. To make sure that no unnecessary programs are running, clean boot the computer before you install one of the programs listed at the beginning of this article. To do this, use the appropriate method for your version of Microsoft Windows.

Microsoft Windows XP

  1. Click Start, and then click Run.
  2. In the Open box, type msconfig, and then click OK.
  3. Click the General tab, click Selective Startup, and then click to clear the following check boxes:
    • Process System.ini file
    • Process Win.ini file
    • Load Startup Items
  4. Click the Services tab, click to select the Hide All Microsoft Servicescheck box, and then click Disable All.
  5. Click OK, and then click Restart to restart the computer.
After you have performed a clean boot of Windows XP, follow these steps to close any programs that remain :
  1. Quit all open programs.
  2. Right-click each icon in the notification area, and then click Exit.

    NOTE: The notification area is located at the far right of the taskbar, near the clock. Some programs listed in the notification area will not have Exit listed on the shortcut menu and you may have to click Quit, Close, or Disable depending on the choices available for that program.
  3. In the Windows Security Menu, press CTRL+ALT+DEL, and then click Task Manager.
  4. In Windows Task Manager, click Applications.
  5. No applications appear under the Task list. If any do applications appear, click to select the application, and then click End Task.
  6. Repeat step 5 until the Task list is empty.
  7. Quit Windows Task Manager.

    NOTE: To restore the computer to use a normal startup, on the General tab in the System Configuration Utility, click Normal Startup - load all device drivers and services, click OK, and then click Restart to restart the computer.
For additional information, click the article number about how to perform a clean boot in Windows XP below to view the article about how to perform a clean boot in Windows XP in the Microsoft Knowledge Base:

310353 How to Perform a Clean Boot in Windows XP

Microsoft Windows Millennium Edition (Me)

  1. Click Start, click Run, type msconfig in the Open box, and then click OK.
  2. On the General tab, click Selective startup.
  3. Click to clear all of the check boxes under Selective startup.
  4. On the Startup tab, click to select the *StateMgr check box.
  5. Click OK. When you are prompted to restart your computer, click Yes. After the computer restarts, Click Start, click Run, type msconfig in the Open box, and then click OK.

    IMPORTANT: Look closely at the General tab to make sure that the check boxes you cleared are still cleared. Continue to step 6 if none of the check boxes is selected. If you see a disabled or gray check box, your computer is not truly "clean-booted" and you may need assistance from the manufacturer of the program that places a check mark back into Msconfig.
  6. After you verify that your computer is clean-booted in step 5, you can isolate the issue. If the original issue does not reoccur after the clean boot, select one item at a time under Selective startup, and then restart the computer to see if the additional entry reproduces the original issue.

Microsoft Windows 98

  1. Click Start, and then click Run.
  2. In the Open box, type msconfig, and then click OK.
  3. On the General tab, click Selective Startup, and then click to clear the following check boxes:
    • Process Config.sys file
    • Process Autoexec.bat file
    • Process Winstart.bat file (if available)
    • Load startup group items
  4. Click the Win.ini tab.
  5. Click the plus sign (+) next to [windows] to expand the branch.
  6. Under the [windows] branch, click to clear the following check boxes:
    • Load=
    • Run=
  7. Click OK.

    When you are prompted to restart the computer, do so.
For additional information about how to clean boot Windows 98, click the article number below to view the article in the Microsoft Knowledge Base:

192926 How to Perform Clean-Boot Troubleshooting for Windows 98

NOTE: To restore your original Startup options, click Normal Startup on the General tab in the System Configuration Utility.

If the issue continues to occur, continue to the "Repair Microsoft Internet Explorer" method.

Microsoft Windows 95

  1. Restart the computer. When you see the "Starting Windows 95" message, press the F8 key, and then select Command Prompt Only from the Startup menu.
  2. At the command prompt, type win, and then press ENTER.

    Press and hold down the SHIFT key until the Windows startup sequence is complete.
  3. Disable any antivirus or disk tool programs installed on the computer.

    For information about how to disable these programs, see the printed or online documentation for the program.
  4. Press CTRL+ALT+DELETE.
  5. In the Close Program dialog box, click any program except Explorer or Systray (which are components of Microsoft Windows), and then click End Task.

    If you receive a message that states that the program is busy or not responding, click End Task again.
  6. Repeat steps 4 and 5 to quit all programs except Explorer and Systray.
For additional information about how to clean boot Windows 95, click the article number below to view the article in the Microsoft Knowledge Base:

177604 Multimedia: Troubleshooting Using Clean Boot of Windows 95

NOTE: To restore your original Startup options, restart the computer normally, and then enable any anti-virus or disk tool programs that are installed on the computer.

For information about how to enable these programs, see the printed or online documentation for the program.

If the issue continues to occur, continue to the next method.

Install DCOM for Windows 95 (Windows 95 Only)

If you want to install one of the programs listed at the beginning of this article on a Windows 95 computer, install the latest version of DCOM for Windows 95 (Dcom95.exe) from the Works CD-ROM or the Works Suite Disc 4 CD-ROM.

If you want to install one of the programs listed at the beginning of this article on a Windows NT 4.0, Windows 98, Windows Me, or Windows 2000 computer, continue to the "Install MDAC in Safe Mode" method.

To install the latest version of DCOM for Windows 95 (Dcom95.exe) from the Works CD-ROM or the Works Suite Disc 4 CD-ROM:
  1. Insert the Works CD-ROM or the Works Suite Disc 4 CD-ROM into the CD-ROM drive. Press and hold down the SHIFT key as you insert the CD-ROM to prevent Works Setup from starting automatically.
  2. Click Start, and then click Run.
  3. In the Open box, type the appropriate line for your version of Works, and then click OK

    Works:

    cd-rom:\redist\ie5\dcom95.exe

    Works Suite:

    cd-rom:\mhp\redist\ie5\dcom95.exe

    where cd-rom is the drive letter of the CD-ROM drive.
  4. Follow the instructions on the screen to install the DCOM95 for Windows 95 update.

Install MDAC

To install MDAC in Safe mode, use the appropriate method for your version of Microsoft Windows.

Windows NT 4.0

If you want to install one of the programs listed at the beginning of this article on a Windows NT 4.0 computer, download and install the latest version of the MDAC update from the following Microsoft Web site: For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

Windows 95, Windows 98, Windows Me, or Windows 2000

To install MDAC in Safe mode:
  1. Insert the Works CD-ROM or the Works Suite Disc 1 CD-ROM into the CD-ROM drive. Press and hold down the SHIFT key as you insert the CD-ROM to prevent Works Setup from starting automatically.
  2. Click Start, point to Find, and then click Files or Folders.
  3. In the Named box, type mdac_typ.exe.
  4. In the Look in box, click the CD-ROM drive, and then click Find Now.
  5. In the list of found files, right-click the Mdac_typ.exe file, and then click Copy.
  6. Right-click an empty area of the Windows desktop, and then click Paste.
  7. Close the Find: Files named mdac_typ.exe window.
  8. Restart the computer in Safe mode. To do this, use the appropriate method for your version of Microsoft Windows.

    Microsoft Windows 98:

    Restart the computer, press and hold down the CTRL key after the computer completes the Power On Self Test (POST), and then choose Safe Mode from the Startup menu.

    Microsoft Windows 95:

    Restart the computer. When you see the "Starting Windows 95" message, press the F8 key, and then choose Safe Mode from the Startup menu.
  9. When Windows starts in Safe mode, click OK.
  10. On the Windows desktop, double-click the Mdac_typ.exe file, and then follow the instructions on the screen to install the MDAC update.
  11. Restart the computer in normal mode.
NOTE: If you are cannot install MDAC in Safe mode, download and install the latest version of the MDAC update from the Microsoft Web site. To do this, refer to the "Windows NT 4.0" method.

Repair Microsoft Internet Explorer

To repair your installation of Internet Explorer:

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. Double-click Microsoft Internet Explorer version.
  4. Click Repair the current installation of Internet Explorer, and then click OK.
NOTE: Internet Explorer 6 is shipped with Windows XP. To add or remove Internet Explorer 6 you must click Start, click Control Panel, click Add/Remove and then select Add/Remove windows components. If you are using the version of Internet Explorer that is included with your operating system, reinstall or repair your operating system.

For additional information, click the article number about how to reinstall or repair Internet Explorer and Outlook Express in Windows XP below to view the article about how to reinstall or repair Internet Explorer and Outlook Express in Windows XP in the Microsoft Knowledge Base:

318378 How to Reinstall or Repair Internet Explorer and Outlook Express in Windows XP

For additional information, click the article number about how to perform an in-place upgrade (reinstallation) of Windows XP below to view the article about how to perform an in-place upgrade (reinstallation) of Windows XP in the Microsoft Knowledge Base:

315341 How to Perform an In-Place Upgrade (Reinstallation) of Windows XP

For additional information about the Internet Explorer Repair Tool, click the article number below to view the article in the Microsoft Knowledge Base:

194177 Description of the Internet Explorer Repair Tool



If the issue continues to occur, continue to the next method.

Uninstall and Reinstall Internet Explorer

If you are cannot repair your installation of Internet Explorer, uninstall Internet Explorer and then reinstall it. To do this, use the following methods in the order in which they are presented.

Uninstall Internet Explorer

NOTE: You must have administrative privileges to install and uninstall Internet Explorer in Windows NT and Windows 2000. This includes having administrative privileges the first time you start your computer after installing or uninstalling Internet Explorer 5.5.

To uninstall Internet Explorer:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. On the Install/Uninstall tab, click Microsoft Internet Explorer and Internet Tools in the list of installed programs, and then click Add/Remove.

    NOTE: If Microsoft Internet Explorer and Internet Tools is missing from the list of installed programs, run Setup.exe from your Internet Explorer\Setup folder. If you are running Windows 2000, run the w2kexcp.exe /u command from your "Internet Explorer\IE Uninstall" folder.
  4. Click Restore the previous Windows configuration, and then click OK.
  5. In the Internet Explorer and Internet Tools Setup dialog box, click OK to restore the previous version of Internet Explorer.
  6. When you are prompted to verify that you want to restore the previous version, click Yes.
  7. When you are prompted to restart the computer, do so.
For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

243266 Uninstalling Internet Explorer 5.01 Removes Outlook Express

Reinstall Internet Explorer 5.5

To reinstall Internet Explorer 5.5:
  1. Insert the Works CD-ROM or the Works Suite Disc 1 CD-ROM into the CD-ROM drive. Press and hold down the SHIFT key as you insert the CD-ROM to prevent the CD-ROM from starting automatically.
  2. Click Start, and then click Run.
  3. In the Open box, type the appropriate line for your version of Works, and then click OK

    Works:

    cd-rom:\redist\ie\ie5setup.exe

    Works Suite:

    cd-rom:\msword\ie5\en\ie5setup.exe

    where cd-rom is the drive letter of the CD-ROM drive.
  4. Follow the instructions on the screen to install Internet Explorer.
If the issue continues to occur, continue to the next method.

Install Works or Works Suite

Install Works or Works Suite.

If the issue continues to occur, clean boot the computer, and then install Works or Works Suite. For information about how to clean boot the computer, refer to the "Install MDAC" method.

MORE INFORMATION

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

270592 Setup Is Unable to Register Tasks or Cannot Find the Work Services File

247532 Works Err Msg: Installer Terminated Prematurely

248263 Works Suite: Error 1305 During Installation

218617 How to Troubleshoot CD-ROM Read Issues

242323 "Internal Error..." Error Message When You Run Setup

242913 Works/HP 2000: "Error 1324" During Installation


Modification Type:MajorLast Reviewed:10/25/2005
Keywords:kberrmsg kbimu kbprb kbsetup KB279625