Terminal Server Clients Cannot See Drives That Are Mapped by SFU's Gateway for NFS (279418)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2

This article was previously published under Q279418

SYMPTOMS

Services for Unix version 2.0 provides a Gateway for NFS service. This service mounts an NFS drive from a remote computer, and then shares the NFS-mounted drive as an SMB shared drive. When the Gateway for NFS service mounts a remote NFS drive, a local drive letter is allocated, for example, Z:. If the Gateway for NFS service is used on a terminal server, users that are logged on to terminal server client sessions may not be able to see the drive that was mapped by the Gateway for NFS service. If a user logs on to the console of a Windows 2000 Terminal Server, the user can see the drive or drives that are mapped by the Gateway for NFS server. However, if the same user connects to the Windows 2000 Terminal Server as a Terminal Server client, the user cannot see the drive or drives that Gateway for NFS has mapped.

CAUSE

Csrss.exe was not including the remapped drive in the session-specific device table because of the drive's type flag.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

The English version of this fix should have the following file attributes or later:
   Date       Time   Version        Size    File name
   ---------------------------------------------------
   24-Oct-01  11:00  5.0.2195.4544   5,392  Csrss.exe
   24-Oct-01  11:00  5.0.2195.4544  35,088  Csrsrv.dll
   30-May-01  00:03  5.0.2195.3649   3,584  Spmsg.dll
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.

MORE INFORMATION

For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:

249149 Installing Microsoft Windows 2000 and Windows 2000 Hotfixes


Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbhowto kbbug kbenv kbfix kbnetwork kbOSWin2000fix kbui kbWin2000PreSP3Fix kbWin2000sp3fix KB279418