SideWinder: You Are Prompted to Insert Software When You Restart Computer (278626)



The information in this article applies to:

  • Microsoft SideWinder Dual Strike
  • Microsoft SideWinder Force Feedback 2
  • Microsoft SideWinder Force Feedback Wheel USB
  • Microsoft SideWinder Game Controller software 4.0
  • Microsoft SideWinder game pad Pro
  • Microsoft SideWinder Precision 2
  • Microsoft SideWinder Precision Racing Wheel
  • Microsoft SideWinder Strategic Commander

This article was previously published under Q278626
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you restart your computer after you install the Microsoft SideWinder Game Controller software version 4.0, you may receive the following error message:
Insert the SideWinder Game Controller software into drive cd-rom.
where cd-rom is the drive letter of your CD-ROM drive.

You receive this error message every time you restart your computer.

CAUSE

This behavior can occur if the installation program cannot remove the temporary files that are installed on your computer by Setup.

RESOLUTION

To resolve this issue, do the following:

Method 1: Remove the Swstubset.exe file from Computer

  1. Close the error message if it's still visible.
  2. Click Start, point to Find, and then click Files or Folders.
  3. In the Named box, type swstubset.exe.
  4. In the Look in box, click My Computer.
  5. Click Find Now.
  6. In the search results list, right-click the Swstubset.exe file, and then click Delete.
  7. When you are prompted to confirm the file deletion, click Yes.
  8. Close the search results window.
  9. Restart the computer.
If the issue continues to occur, use Registry Editor to remove the appropriate registry key for your game controller.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, and then click Run.
  2. Start Registry Editor.
  3. Delete the appropriate registry key for your game controller:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Sidewinder ForceFeedback 2 Shell
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Sidewinder Precision 2 Setup Shell
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Sidewinder Strategic Commander Shell
    					
  4. Quit Registry Editor.
  5. Restart the computer.

Method 2:

Restart Windows in Safe mode

  1. Restart your computer, press and hold down the CTRL key when you see the Starting Windows 98 message, and then select Safe Mode from the Startup menu.
  2. When Windows starts in Safe mode, click OK.

Uninstall SideWinder Software while in Safe Mode

  1. Click Start, point to Settings, click Control Panel, and then double-click Add/Remove Programs.
  2. Click the SideWinder software entry for your game controller, and then click Add/Remove.
  3. Follow the instructions on your screen to uninstall the SideWinder software.

Reinstall the SideWinder Game Controller Software

When the Microsoft Windows startup sequence is complete, reinstall the SideWinder Game Controller software. When Setup is finished, you should not need to restart the computer and you should proceed directly to the Connection and Test phase of Setup.

NOTE: If your game controller does not work properly in the Test phase of Setup, disconnect the game controller from the Universal Serial Bus (USB) port in your computer, and then reinstall the SideWinder Game Controller software again.

Do not connect your game controller to the USB port in your computer until you are prompted to do so by Setup.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kberrmsg kbHardware kbprb KB278626