MCIS 2.5 HMI Site May Return "Server Busy" Error Under Heavy Load (275909)



The information in this article applies to:

  • Microsoft Commercial Internet System 2.5

This article was previously published under Q275909

SYMPTOMS

When under a heavy load, the Microsoft Commercial Internet System (MCIS) 2.5 HTML Mail Interface (HMI) service may return the following error:
HTTP 500: Server busy

CAUSE

There is a bug in the internal processing of the Renobj.dll file that, when placed under stress, can suspend the processing of a request to the site. When this occurs, the INETINFO process can run out of Active Server Pages (ASP) threads, which leaves the server in a permanently busy state.

WORKAROUND

To work around this problem, stop and restart the MCIS 2.5 HMI service. In addition, you may have to restart your computer.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Commercial Internet System Service Pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date      Time     Version      Size    File name     Platform
   --------------------------------------------------------------
   02/11/2000  17:46  8.0.393.0    263,952 Renobj.dll    x86
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

You can see this problem when you use Performance Monitor to monitor the following counters in the Active Server Pages object:
  • Requests Executing: This counter rises gradually to the maximum number of threads that are configured for the service and remains constant even when there is no activity on the server.
  • Requests Queued: This counter rises exponentially when the problem occurs and does not diminish even when there is no activity on the server.
  • Requests Rejected: This counter rises exponentially when the problem occurs and does not diminish even when there is no activity on the server. Typically, this counter rises shortly after the Requests Queued counter rises.

Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB275909