SMS: Software Distribution to Stops Because Inbox Manager Cannot Remove the Inboxlck.tok File (275617)
The information in this article applies to:
- Microsoft Systems Management Server 2.0 SP2
- Microsoft Systems Management Server 2.0 SP3
This article was previously published under Q275617 SYMPTOMS
Before the release of Systems Management Server (SMS) Service Pack 2 (SP2), Inbox Manager periodically could not replicate files to the Client Access Points (CAPs) because the files were in use by client computers. Because of the added functionality in SMS SP2, Inbox Manager can create a lock file on the CAP to prevent client access when Inbox Manager updates the Inboxes on the CAP. The lock file is created for each Inbox that Inbox Manager replicates to the CAP; however, there is a situation where Inbox Manager may not remove the Inboxlck.tok file from the Inbox. When this occurs, the processing of offers by clients may be prevented. Advertised Program Manager (APM) in SP2 checks for the Inboxlck.tok file in the Offerinf.box file on the CAP. If the Inboxlck.tok file is present on the CAP, offer processing is prevented.
The presence of the Inboxlck.tok file may also prevent clients from upgrading the Software Distribution component to a newer version, from a QFE or Service Pack applied to the Site server. When this happens, the status of the Software Distribution component on the clients would remain at "Install pending."
CAUSE
This problem occurs because Inbox Manager attempts to delete the Inboxlck.tok file after the Inbox is updated. This deletion may not work if the Inboxlck.tok is opened by a client. The clients attempt to open the Inboxlck.tok file to verify that it exists.
WORKAROUND
If the symptoms are observed during software distribution on a site running SMS 2.0 SP2 or SMS 2.0 SP3, please apply the fix discussed in the "Resolution" section of this article. If however the symptoms are observed after a QFE application or Service Pack upgrade, please use the following workaround to clear the lock file:
- Stop the SMS_INBOX_MANAGER component on the Site Server using the SMS Service Manager.
- Using Computer Management or Server Manager, close all Open File connections on \CAP_xxx\clicomp.box\SWDist. Repeat this step for all affected CAPs.
- Start the SMS_INBOX_MANAGER component on the Site Server, and verify that it removes the lock file.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Systems Management Server version 2.0. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
288239 SMS: How to Obtain the Latest Systems Management Server 2.0 Service Pack
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Systems Management Server 2.0 Service Pack 4.
Modification Type: | Minor | Last Reviewed: | 4/14/2006 |
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Keywords: | kbQFE kbHotfixServer kbBug kbenv kbfix kbsms200preSP4fix KB275617 |
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