"[FrontPage vinavbar component]" appears when you browse a page (273781)



The information in this article applies to:

  • Microsoft Visual InterDev 1.0
  • Microsoft Visual InterDev 6.0

This article was previously published under Q273781

SYMPTOMS

When you are browsing a page, the text "[FrontPage vinavbar component]" appears.

CAUSE

The browser displays "[FrontPage vinavbar component]" when the page uses the NavBar Design-Time Control (DTC), and one or more of the following conditions is present:
  • Microsoft FrontPage Server Extensions (FPSE) is not installed or is not functioning properly.
  • The NavBar bot is not installed properly.
  • The NavBar bot cannot read your Web application's links properly.
There are many causes for these three general conditions.

FPSE 2002 breaks the NavBar and there is no workaround other than to downgrade the server to FPSE2000.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

303142 Navigation bar does not appear, error on server console

RESOLUTION

Because there are many possible causes for this problem, there are several possible solutions. The solutions also vary depending on the configuration of the server against which you are developing.

Operating SystemServer Configuration
Microsoft Windows 9xPersonal Web Server (PWS) with FPSE 98 or FPSE 2000
Microsoft Windows NT 4.0PWS or Internet Information Server (IIS) with FPSE 98 or FPSE 2000
Microsoft Windows 2000IIS 5.0 with FPSE 2000

Primarily, this article addresses IIS with FPSE 2000 but briefly explains how to apply these steps to Personal Web Server (PWS) and/or FPSE 98.

How to Determine Your FPSE Version

To determine which version of FPSE you are running on your IIS server, browse to http://server name/_vti_bin/shtml.dll. You should receive one of the following error messages:
FrontPage 2000 Server Extensions (FPSE 2000):
Cannot run the FrontPage Server Extensions' Smart HTML interpreter on this non-HTML page: ""

-or-

FrontPage 98 Server Extensions (FPSE 98):
FrontPage Error. User: please report details to this site's webmaster. Webmaster: please see the server's application event log for more details.
If you do not receive one of these error messages, you must reinstall FPSE. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

205696 How to install FrontPage 2000 Server Extensions for Internet Information Server

It is strongly recommended that you upgrade your IIS or PWS server to the latest version of FPSE. You can download FPSE 2000 with the latest service releases from the following Microsoft Web site:

Troubleshooting Steps for IIS with FPSE 2000

Use one of the following solutions for IIS with FPSE 2000:
NOTE: After you apply each of these solutions, you must remove existing NavBar DTCs from your HTML and/or Active Server Pages (ASP) pages and add them again from the toolbar to re-initialize them.

Recalculate Links

(This is the most common solution)
  1. On the Start menu, click Run.
  2. Browse to the folder that contains the Fpsrvadm.exe file (which is Common Files\Microsoft Shared\Web server extensions\40\Bin\Fpsrvadm.exe by default). The Common Files folder is usually located at C:\Program Files\Common Files.
  3. Run Fpsrvadm.exe.
  4. Select option 8 - Recalculate links.

Replace the NavBar Control

  1. In Visual InterDev, open a page that has a NavBar control that is failing.
  2. Right-click the control, and then click Properties.
  3. Write down the various properties settings.
  4. Delete the NavBar control from the page, and replace it with a fresh copy from the toolbox.
  5. Set the new control's properties according to your notes (the settings from the previous control).
  6. If this fixes the problem, repeat these steps for all NavBar controls that are failing.

Check Server Extensions

  1. On the Start menu, point to Programs, point to Administrative Tools, and then click Internet Services Manager.
  2. Browse to the folder for your Web site (or sub Web) under the root Web.
  3. Right-click your sub Web folder, and then click All Tasks (or Tasks in Windows NT 4.0). Click Check Server Extensions.

    NOTE: If your Web folder is located in an NTFS directory, the Check Server Extensions option prompts you to tighten security. However, this is not required to repair the problem with the NavBar DTC. For additional information about the tighten security option, click the following article number to view the article in the Microsoft Knowledge Base:

    216820 "Check Server Extensions" grants extra permissions

  4. If the problem still occurs, follow the steps in the Replace the NavBar Control section.

Manually Remove and Reapply Server Extensions

  1. Close Visual InterDev.
  2. On the Start menu, point to Programs, point to Administrative Tools, and then click Internet Services Manager.
  3. Browse to the folder for your Web site (or sub Web) under the root Web.
  4. Right-click your sub Web folder, and then click All Tasks (or Tasks in Windows NT 4.0). Click Convert Server Extensions Web to Directory.
  5. Open the Windows File Explorer, browse to the physical folder for the Web site (which is C:\InetPub\wwwroot\webname by default), and delete all of the _vti folders from the main folder, as well as any sub-folders for the Web site.

    If you use Internet Services Manager instead of Windows Explorer, you may notice one more _vti folder (_vti_bin), which you should not delete. If you delete _vti_bin by mistake, follow these steps to replace it:
    1. In Internet Services Manager, create a new virtual directory that points to your ISAPI directory (usually C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\ISAPI).
    2. Right-click the new virtual directory, and then click Properties.
    3. On the Virtual Directory tab, chage the execute permissions to include both scripts and executables.
  6. In Internet Services Manager, browse back to folder for the Web site. Right-click the Web folder, and then click All Tasks (or Tasks in Windows NT 4.0). Click Configure Server Extensions. The Server Extensions Configuration Wizard guides you through the rest of the installation.
  7. Open the project in Visual InterDev.
  8. Open the site diagram file. If you are prompted to use the local copy or the newer copy on the server, select to use the local copy. The master copy is probably blank, and you must repopulate it with your Web pages and their hierarchy (just add two or three pages to it, and test it before you completely repopulate it).
  9. If the problem still occurs, follow the steps in the Check Server Extensions section again.
  10. If the problem still occurs, follow the steps in the Recalculate Links section again.
  11. If the problem still occurs, follow the steps in the Replace the NavBar Control section again.
  12. If the problem still occurs, delete the site diagram, and create a new one (just add two or three pages to it, and test it before you completely repopulate it).
  13. If the problem still occurs, start this section (Manually Remove and Reapply Server Extensions) from the beginning, but delete (or move) your site diagram (.wdm) file along with the _vti directories. You must create a new site diagram (just add two or three pages to it, and test it before you completely repopulate it).

Troubleshooting Steps for FPSE 98

  • If you cannot upgrade to FPSE 2000, you must install FPSE 98 from disk 2 of the Microsoft Visual Studio installation CDs. If you install FPSE 98 from any other source (for example, from the Microsoft Web site), it does not include the NavBar DTC.
  • Verify that the Vinavbar folder exists at FrontPage program folder\Version3.0\Bots\Vinavbar. If it does not exist, FPSE is either not installed or was installed from a location other than the Visual Studio CD. Either install a newer version of FPSE or reinstall FPSE 98 from disk 2 of the Visual Studio CDs.
  • Follow the steps to Recalculate Links. For step 2, you can find Fpsrvadm.exe in FrontPage program folder\Version3.0\Bin\Fpsrvadm.exe.

Troubleshooting Steps for Personal Web Server (PWS)

With FPSE 98

Use the troubleshooting steps for IIS with FPSE 2000 except:
  • Use the FrontPage Server Administrator instead of the Internet Services Manager. To open the FrontPage Server Administrator, on the Start menu, click Microsoft Personal Web Server.
  • When you follow the steps to Check Server Extensions, the equivalent button in the FrontPage Server Administrator is either Check or Check and Fix.

With FPSE 2000

Use the troubleshooting steps for IIS with FPSE 2000, except use the Server Extensions Administrator instead of the Internet Service Manager. To open the Server Extensions Administrator, on the Start menu, click Microsoft Personal Web Server.

REFERENCES

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

193232 Readme.txt for Visual InterDev 6.0

191278 Visual InterDev 6.0 READMEVI.HTM file


Modification Type:MajorLast Reviewed:5/11/2006
Keywords:kbCtrl kbExtension kbprb kbServer KB273781