Web Pages May Not Be Updated Correctly (271690)



The information in this article applies to:

  • Microsoft Internet Explorer 5.5 for Windows NT 4.0
  • Microsoft Internet Explorer 5.01 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 2
  • Microsoft Internet Explorer 4.0 for Windows NT 4.0
  • Microsoft Internet Explorer 3.02 for Windows NT 4.0
  • Microsoft Internet Explorer 3.01 for Windows NT 4.0
  • Microsoft Internet Explorer 3.0 for Windows NT 4.0
  • Microsoft Internet Explorer 2.0 for Windows NT 4.0
  • Microsoft Internet Explorer 5.5 for Windows 98
  • Microsoft Internet Explorer 5.01 for Windows 98 SP 1
  • Microsoft Internet Explorer 5.0 for Windows 98
  • Microsoft Internet Explorer 4.01 for Windows 98 SP 2
  • Microsoft Internet Explorer 5.5 for Windows 2000
  • Microsoft Internet Explorer 5.01 for Windows 2000 SP 1

This article was previously published under Q271690

SYMPTOMS

When you view Web pages that contain content that is updated frequently, such as stock quotes or news, the pages may not be refreshed to display new content.

CAUSE

This issue can occur if the clock on your computer is incorrectly set to a time or date in the past.

RESOLUTION

To resolve this issue, correct the time, date, and time zone on the computer by using the Date/Time Properties dialog box. To view the Date/Time Properties dialog box, double-click the clock on the taskbar.

To work around this issue on the Web server, set the Expires header for the Web page that is being sent to "0" instead of a specific date. Web browsers and caches interpret this setting to mean that the Web page expires immediately, instead of expiring at a specific date or time.

STATUS

This behavior is by design.

MORE INFORMATION

Web servers can send Web pages that contain information about when those Web pages expire. When a Web page expires, the Web browser should send a request for a new version of the Web page. If the computer's clock is set to a date or time in the past, Internet Explorer may incorrectly determine that the expiration date that was sent with the Web page has not yet passed. Therefore, Internet Explorer does not request the latest version of the Web page from the Web server.

REFERENCES

For a description of the Expires header, view section 14.21 of the Request for Comments (RFC) 2616 (HTTP/1.1) document at the following Internet Engineering Task Force Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Modification Type:MajorLast Reviewed:11/26/2003
Keywords:kbprb KB271690