WD2002: Problems Saving or Opening Files with Extended Characters on a NetWare Server (269043)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0

This article was previously published under Q269043

SYMPTOMS

You may experience any of the following issues:
  • When you try to open a file with extended characters in the file name that is located on a NetWare volume by using Gateway Service for NetWare or Client Services for NetWare, you may not be able to open the file and you may receive an error message. The error message that you receive varies, depending on the program that is attempting to open the file.

    -or-

  • When you try to save or copy files with extended characters in the file name to the NetWare server, some of the characters in the file name may change.

    -or-

  • When you try to locate a folder on a NetWare server by using Windows Explorer, files with extended characters in the file name may not display correctly.

CAUSE

The current default regional settings do not provide a character mapping for the extended characters.

Characters with a tilde (~) over them are examples of extended characters that may not appear correctly.

RESOLUTION

To resolve this issue, use the Regional tool in Control Panel to change the default regional settings to the same regional settings that you are using. To create the extended characters, use either of the following methods.

Microsoft Windows NT 4.0

  1. Click Start, point to Settings, and then click Control Panel.
  2. In Control Panel, double-click Regional Settings.
  3. On the Regional Settings tab, click the appropriate language in the list, and then click to select the Set as system default locale check box.
  4. Restart your computer when you are prompted.

Windows 2000

  1. On the toolbar click Start, point to Settings, and then click Control Panel.
  2. In Control Panel, double-click Regional Options.
  3. On the General tab, click Set Default, click the appropriate language in the box, and then click OK.
  4. Restart your computer when you are prompted.

Modification Type:MajorLast Reviewed:5/14/2003
Keywords:kbfile kbNetWareService kbprb KB269043