Offline Print Queues May Cause Print Jobs to Hang When Print Queue Is Online (268334)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional

This article was previously published under Q268334

SYMPTOMS

In Windows 2000, you can set a print queue for offline use. You can use this functionality to print a document while you are not connected to the network, or when a print server is not available. When the network or print server is available again, you can set the print queue to be online and print the document.

In some cases, if you set a print queue to offline, print some documents, and then reboot your computer, the documents that you printed become "stuck" or "hung" in the print queue when you set the print queue to be online again. You must clear these documents before you can print any additional documents.

CAUSE

This issue occurs because a temporary access token is generated when you initially print the documents and they are stored in the print queue. This access token is lost after the reboot.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:11/20/2003
Keywords:kbenv kbprb kbprint w2000print KB268334