"The Pipe Has Ended" Error Message Occurs When You Crawl Exchange Server Public Folders (265077)



The information in this article applies to:

  • Microsoft Site Server 3.0

This article was previously published under Q265077

SYMPTOMS

When you crawl an Exchange Server public folder, the following error message may occur in the gather log:
"The pipe has ended"

CAUSE

The error message occurs in the gather log for each message that contains multiple attachments when an office file (.doc, .xls, .ppt, and so on) is followed by an Adobe .pdf or any .html file.

RESOLUTION

To resolve this problem, obtain the latest service pack for Site Server 3.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

219292 How to Obtain the Latest Site Server 3.0 Service Pack

STATUS

Microsoft has confirmed that this is a problem in Site Server 3.0.

This problem was first corrected in Site Server 3.0 Service Pack 4.

MORE INFORMATION

"The pipe has ended" error message occurs due to a timeout in Gthrsvc.exe. The Gather service, Gthrsvc.exe, spawns a fltrdmn process that actually does the filtering. Fltrdmn loads the appropriate filter DLLs for each file that is encountered. The Gthrsvc.exe process and the fltrdmn process communicate over a named pipe. The Gather service terminates the spawned fltrdmn process when there is no communication over the pipe after a certain timeout, which results in the error message.

Note that this error message is generic and only indicates that the pipe was timed out due to a lack of communication between the two processes. This can occur for any number of other reasons. The solution in this article may not apply to other occurrences of this error message.

Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbbug kbExchange550preSP4fix kbExchange550sp4Fix kbfix KB265077