Matrox Diagnostic Program Does Not Recognize Version of DirectX Installed (264542)



The information in this article applies to:

  • Microsoft Windows Millennium Edition

This article was previously published under Q264542
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

SYMPTOMS

When you run the Matrox diagnostic software included with their Powerdesk utility for your graphics card, you may receive the following error message:
Is recent DirectX software installed?
Warning:Old version of DirectX installed
Description: Programs using DirectX may run slower
Reinstall DirectX from your Matrox CD-ROM or your system disks

CAUSE

This occurs because the Matrox diagnostic program detects only a small range of DirectX versions. Windows Millennium (Me) includes DirectX 7.1 which is a program that the Matrox diagnostic program does not recognize.

RESOLUTION

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

To resolve this issue, download and install the latest drivers and Powerdesk utility from the Matrox website:

Modification Type:MinorLast Reviewed:1/14/2006
Keywords:kbdisplay kbgraphic kbHardware kbprb kbsetup KB264542