XADM: Error Message 0xC103798A During Key Management Service Setup (264251)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q264251

SYMPTOMS

When you install Key Management Service, the following error message may be displayed:
Setup failed while installing sub-component Key Management Service with error code 0xC103798A (please consult the installation logs for a detailed description). You may cancel the installation or try the failed step again.
The Exchange Setup Progress.log file may contain an error message that is similar to the following:
E:\EXCHSRVR\bin\kmserver.exe -I ???????? -X "c=US, o=\"organization\", ou=\"server\", cn=Certificate Authority" failed, returning error code -1 (The operation was cancelled.).

CAUSE

This issue can occur if a previously installed Key Management Service database still exists in the target installation folder. By default, this folder is the following:

drive:\Program Files\Exchsrvr\Kmsdata

RESOLUTION

To resolve this issue, empty the target installation folder. If previously installed Key Management Service database files exist, do not delete those files, but move them to a safe location in case you need them again. If password (.pwd) files exist for the previous Key Management Service database, save those files also. The database is encrypted, and you cannot gain access to the database if the database's previous password is lost.

After you empty the target installation folder, click Retry to finish the new installation.

Modification Type:MinorLast Reviewed:4/21/2005
Keywords:kberrmsg kbprb KB264251