Missing File Conversion Associations After Upgrading to ActiveSync (264016)



The information in this article applies to:

  • Microsoft ActiveSync 3.0
  • Microsoft ActiveSync 3.1
  • Microsoft ActiveSync 3.6, when used with:
    • the operating system: Microsoft Windows NT 4.0

This article was previously published under Q264016

SYMPTOMS

When synchronizing Microsoft Word or Microsoft Excel files from your desktop to a handheld device, you may experience the following error message:
Error converting File

Conversion failed.
The system cannot find the specified file.
After you click OK, you may receive the following error message:
ActiveSync Error

One message could not be read from Microsoft Outlook due to error 80070003. This item will not be synchronized with the mobile device.

CAUSE

This behavior can occur after you upgrade Microsoft Windows CE Services 2.2 to ActiveSync. During the upgrade process, only the administrator's profile is upgraded. Any existing user accounts don't get their information properly updated, even if the associations are present before the upgrade. On the other hand, new users added after ActiveSync is installed typically find that file conversion has taken place correctly and associations have been properly created.

WORKAROUND

To work around this issue, make a local user a member of the administrators group, and then log on as that user before performing the upgrade. Afterwards, log on as the local administrator and remove the local user from the administrators group. At this point, both the local administrator and the existing user have the proper conversion settings, as do any newly added users.

Modification Type:MinorLast Reviewed:8/18/2005
Keywords:kbenv kbprb KB264016