You receive a "0xC007054B" error message when you run the Exchange 2000 Server or Exchange Server 2003 Setup program (264008)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition, Service Pack 1 (SP-1)
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition, Service Pack 1 (SP1)
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server SP3
  • Microsoft Exchange 2000 Server SP2
  • Microsoft Exchange 2000 Server SP1
  • Microsoft Exchange 2000 Server

This article was previously published under Q264008

SYMPTOMS

When you are running the Microsoft Exchange 2000 Server or Microsoft Exchange Server 2003 Setup program, or when you are installing a service pack update, you may receive one of the following error messages:
  • If you are installing a new Exchange computer into the organization, you may receive the following error message:
    Setup failed while installing sub-component Site Replication Service with error code 0xC007054B (please consult the installation logs for a detailed description). You may cancel the installation or try the failed step again.
  • If you are reinstalling Exchange, or if you are installing a service pack update, you may receive the following error message:
    The component "Microsoft Exchange Messaging and Collaboration Services" cannot be assigned the action "Update" because: Setup encountered an error while trying to contact the Windows Active Directory.
Additionally, the following entries may be logged in the Exchange Server Setup log:
  • DS or RPC is busy. Sleep xxxx msec
  • Error code 0xC007054B (1355): The specified domain either does not exist or could not be contacted.

CAUSE

This issue can occur if there is a problem with the connection to the Active Directory for this domain. If the Exchange computer is in the child domain, the Setup program or the service pack update requires a successful GetDCName call to obtain the name of the domain controller for the root domain. This issue can occur if port 389 between the root domain controllers is closed.

RESOLUTION

To resolve this issue, make sure that network connectivity and name resolution work between the installing server and the domain controller.

If the Exchange computer is in a child domain, make sure that any firewalls between the two domains and the root domain have port 389 open for Lightweight Directory Access Protocol (LDAP) communication.

Make sure that there are entries for the domain in the Domain Name System (DNS).

After you resolve any connectivity problems, complete the Exchange Server Setup program by clicking Retry in the error message.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kberrmsg kbprb KB264008