Kernel Breakin Request Hangs the System During Debugging (263473)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional

This article was previously published under Q263473

SYMPTOMS

While you are debugging Windows 2000 by using a kernel node debugger, the CSRSS.exe process may stop responding (hang).

CAUSE

When the kernel receives a breakin request from a kernel mode debugger, the CSRSS.exe process loses the local procedure call (LPC) message and stops the process. The symptoms you see are an inability to stop or end the process. The only recourse is to restart the computer.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

The English version of this fix should have the following file attributes or later:

   Date        Time    Version        Size       File name 
   ---------------------------------------------------------- 
   05/18/2000  07:06p  5.0.2195.1624  1,618,432  ntkrnlmp.exe 
   05/18/2000  07:07p  5.0.2195.1624  1,618,432  ntkrnlpa.exe 
   05/18/2000  07:07p  5.0.2195.1624  1,638,912  ntkrpamp.exe 
   05/18/2000  07:06p  5.0.2195.1624  1,596,352  ntoskrnl.exe 

				



STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 2.

MORE INFORMATION

For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:

249149 Installing Microsoft Windows 2000 and Windows 2000 Hotfixes


Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbWin2000PreSP2Fix KB263473