OL2000: You Cannot Save Sent E-mail Message to a Public Folder (260099)



The information in this article applies to:

  • Microsoft Outlook 2000

This article was previously published under Q260099

SYMPTOMS

When you click the Options button in an e-mail message and then choose a Microsoft Exchange Server public folder as the location to store the sent e-mail message, you may receive the following error message:
The folder you have selected in not a subfolder of the default store. To select a different folder, click OK.

CAUSE

This is a limitation of where sent e-mail messages can be saved when you use this feature.

WORKAROUND

To work around this problem, add the public folder to your address book, and then add the public folder address to either the Cc field or the Bcc field in your e-mail message.

For additional information about how to add a public folder to the Exchange Global Address List, click the article number below to view the article in the Microsoft Knowledge Base:

225016 XADM: How to Change the Recipients Container for PF Mailboxes

To add the public folder to your personal address book:
  1. Right-click the public folder, and then click Properties.
  2. Click the Administration tab. If you do not have adequate permissions in the folder, the Administration tab is not available. However, you can click the Summary tab instead.
  3. Click Personal Address Book.
If you cannot add the public folder to an address book, you can use Visual Basic Scripting Edition (VBScript) with a custom e-mail message form to programmatically save a copy of the item to the public folder when it is sent. To programmatically save a copy of the item to the public folder when it is sent:
  1. Implement the Send event.
  2. Use the Save method to save the message.
  3. Use the Copy method to make a copy of the mail message.
  4. Use the Move method to move the copied message to the public folder.

MORE INFORMATION

As part of an Outlook custom form solution, you may want to change the location where a sent e-mail message is stored to a public folder. This allows you track the e-mail messages that are sent from the public folder.

The default store location is the set of folders that receive your incoming e-mail messages. This can be either a Microsoft Exchange Server mailbox or a Personal Folders file (.pst).

REFERENCES

For additional information about available resources and answersto commonly asked questions about Outlook solutions, click the article number below to view the article in the Microsoft Knowledge Base:

146636 OL2000: Questions About Custom Forms and Outlook Solutions


Modification Type:MajorLast Reviewed:10/8/2003
Keywords:kbprb KB260099