PRB: User Unable to Browse Data After Cube is Processed (259288)



The information in this article applies to:

  • Microsoft SQL Server OLAP Services 7.0

This article was previously published under Q259288

SYMPTOMS

After a cube is processed, the Microsoft SQL Server OLAP Manager processing window reports that the processing completed successfully but the user is unable to browse the cube data. The OLAP Manager cube browser or other display tool displays #ERR in all the cells. The data folder for the cube which should be in \Program Files\Olap Services\Data\ does not exist but a shadow folder ('S1) exists instead.

CAUSE

OLAP Services is not able to successfully delete the old cube folder and rename the shadow folder after the processing completes if another process has locked the data folder or files for the cube.

WORKAROUND

To browse the data, you can either reprocess the cube when nothing else has the data files or directory locked or you can rename the shadow directory manually. The preferred method is to schedule the processing of the cube at a time when no other process accesses the cubes data files or directory.

Modification Type:MajorLast Reviewed:10/16/2003
Keywords:kbprb KB259288