Windows 95 Clients Hang at Startup Randomly (256894)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

This article was previously published under Q256894

SYMPTOMS

Systems Management Server (SMS) clients that are running Microsoft Windows 95 may stop responding (hang) randomly at startup. When this occurs, both Explorer.exe and Microsoft Office Toolbar are displayed as "Not responding" in the Close Program dialog box; you must reboot the client computer to continue.

CAUSE

This behavior can occur if two Clisvc95.exe threads are running at the same time. The first thread owns an object that the second thread needs. Because one thread is not responding to a system broadcast message, the rest of the system hangs pending the message delivery. Both threads are attempting to load a dynamic-link library (DLL); because they currently own each other's lock, the process deadlocks.

RESOLUTION

To resolve this problem, obtain the latest service pack for Systems Management Server version 2.0. For additional information, please see the following article in the Microsoft Knowledge Base:

236325 How to Obtain the Latest Systems Management Server 2.0 Service Pack

STATUS

Microsoft has confirmed this to be a problem in Systems Management Server version 2.0. This problem was first corrected in Systems Management Server version 2.0 Service Pack 2. For additional information regarding this fix please the following article:

244034 SMS: Windows 95/98 Clients Hang Opening E-mail Attachments or Associated Files


Modification Type:MinorLast Reviewed:6/14/2005
Keywords:kbBug kbprb kbsms200fix KB256894