Works: Calendar Closes When You Attempt to Merge Birthdays and Anniversaries from Address Book (255631)



The information in this article applies to:

  • Microsoft Works 2000
  • Microsoft Works 6
  • Microsoft Works Suite 2000
  • Microsoft Works Suite 2001

This article was previously published under Q255631

SYMPTOMS

When you add a new birthday or anniversary or change an existing one in the Microsoft Works Address Book, and then click Birthdays on the Edit menu, Works Calendar quits unexpectedly, and you may briefly see the following Dr. Watson error message:
WksCal.exe has generated errors and will be closed by Windows.
You will need to restart the program.

An error log is being created.
In addition, you may experience one of the following symptoms:
  • When you restart Works Calendar, you are prompted to update your Calendar and Address Book.

    If you click Yes, update now, Works Calendar starts, and the birthday or anniversary dates are added to the Calendar.

    If you click No, I'll update later, Works Calendar starts, and the birthday and/or anniversary dates are not added to the Calendar.
  • When you restart Works Calendar, you are not prompted to update your Calendar and Address Book, Works Calendar starts, and the birthday and/or anniversary dates are not added to the Calendar.

CAUSE

This behavior can occur if you run Works on a Microsoft Windows 2000-based computer.

RESOLUTION

To work around this issue, use the appropriate method.

NOTE: The following methods do not prevent Works Calendar from quitting unexpectedly when you click Birthdays on the Edit menu. However, these methods ensure that Address Book dates are merged into the Calendar. Existing data in the Calendar and the Address Book is not affected.

Reinstall Works

If you cannot update your Calendar and Address Book when you restart Works Calendar:
  1. Quit all programs that are running on the computer.
  2. Make sure that you are logged on as a member of the Administrators group.
  3. Insert the Works or the Works Suite Disc 1 CD-ROM into the CD-ROM drive. Press and hold down the SHIFT key as you insert the CD-ROM to prevent the CD-ROM from starting automatically.
  4. Click Start, point to Settings, and then click Control Panel.
  5. Double-click Add/Remove Programs.
  6. In the list of installed programs, click the version of Microsoft Works that is installed on your computer, and then click Change/Remove.
  7. On the Welcome back screen, click Next.
  8. On the Options screen, click Reinstall, and then click Next.
  9. On the You're done screen, click Finish.
  10. When you are prompted to restart the computer, click Yes.
  11. Start Works Address Book.
  12. Add, change, or delete a birthday or anniversary date.
  13. Start Works Calendar.
  14. On the Edit menu, click Birthdays.

    NOTE: Works Calendar still quits unexpectedly.
  15. Restart Works Calendar.
  16. When you are prompted to update your Calendar and Address book, click Yes, update now.

    NOTE: Verify that the Don't show this message again check box is cleared.
  17. If you changed a birthday or anniversay for an existing contact in the Address Book, click the correct date when you are prompted to do so, and then click Update Now.
  18. When you receive the message that the Calenday was updated successfully, click OK.

    NOTE: Verify that the Update the Calendar with new birthday and anniversary information from the address book each time you open the calendar check box is selected.

Disable Dr. Watson Error Messages

If you do not want to receive Dr. Watson error messages:
  1. Click Start, and then click Run.
  2. In the Open box, type drrwtsn32, and then click OK.
  3. Click to clear the Visual Notification check box, and then click OK.
NOTE: The Dr. Watson error log is still created for troubleshooting purposes.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:6/30/2004
Keywords:kbbug kbenv kberrmsg kbpending KB255631