Error Messages When MMS Database Directory Size Reaches Limit (253862)



The information in this article applies to:

  • Microsoft Metadirectory Services 2.1
  • Zoomit VIA 1.0
  • Zoomit VIA 2.1

This article was previously published under Q253862

SYMPTOMS

When you log on to the Compass client, you may receive the following error message:
Unable to bind
If you try to stop and start the Zoomit Server service, the following error message occurs:
Dr. Watson : **Essential OID definition missing, failed to lookup user password**.

CAUSE

There is a 2-gigabyte (GB) size limit on the X500.db database file in Metadirectory Services. When this size limit is reached, the error messages listed above occur and the directory is inaccessible.

RESOLUTION

To resolve this issue:
  1. Restore from the most recent working backup.
  2. Immediately run the Via Compact utility.
Using the Via Compact utility regularly can keep your database compact, reducing the chance that the database will reach the size limit. For more information about the Via Compact utility, please see the following article in the Microsoft Knowledge Base:

250484 How to Use the VIA Compact Utility in Microsoft Metadirectory Services

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:10/27/2003
Keywords:kbenv kberrmsg kbprb KB253862