Delay Delivery Status Notifications and TURN/ETRN/ATRN (247129)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server

This article was previously published under Q247129

SYMPTOMS

In Microsoft Exchange 2000 Server and in Microsoft Exchange Server 2003, messages that are held in the queue for TURN/ETRN/ATRN may cause Delay Delivery Status Notifications (DSNs) to be generated. This behavior occurs when a connection closes and a specific time period elapses. The situation can become critical for environments where most of the outbound mail is queued. The Delay DSNs add to the queue lengths, and you may lose control of the server's state because of the large number of messages.

CAUSE

This behavior can occur if the Delay Notification time is set too low.

WORKAROUND

Ensure that the Outbound Delay Notification setting is high enough. The default is 12 hours. Use the following procedure to adjust this setting on your Exchange server:
  1. Start Exchange System Manager, and then click your server.
  2. Under your server, double-click the Protocols folder.
  3. Under the Protocols folder, double-click the SMTP folder.
  4. Under the SMTP folder, click your SMTP virtual server.
  5. Right-click the virtual server, and then click Properties. The Delay Notification setting is located on the Delivery tab. Adjust the setting for your environment.
  6. Repeat this procedure for each SMTP virtual server that you have created.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbinfo KB247129