BUG: COM+ Does Not Respond When You Import Registered Components (246871)
The information in this article applies to:
This article was previously published under Q246871 SYMPTOMS
When you upgrade a computer from Windows 98 to Windows 2000, the COM+ Explorer stops responding when you try to import registered components.
CAUSE
When you upgrade from Windows 98 to Windows 2000, the registry has duplicate CLSIDs, which causes the COM+ Explorer to stop responding.
RESOLUTION
To work around this problem, do one of the following: - Import the component .dll file that you want to configure in COM+ programmatically through the COM+ Administration SDK interface ICOMAdminCatalog.
-or-
- In the COM+ Explorer, use the "Install new component" option to install components.
NOTE: The "Import Component(s) that are registered" option is only used for legacy support.
-or-
- Search for duplicate (bogus) CLSIDs, and then delete them.
STATUSMicrosoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Major | Last Reviewed: | 2/21/2002 |
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Keywords: | kbbug kbSysAdmin KB246871 |
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