Winsock call fails when user does not have local Administrator rights (245678)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 SP6
  • Microsoft Windows NT Workstation 4.0 SP6
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP6

This article was previously published under Q245678

SYMPTOMS

After you apply Windows NT 4.0 Service Pack 6, Winsock calls may not work properly. Generally the problem manifests itself when a program attempts to connect to a server. You may see an application layer error like:
Could not connect to server.

or

Access denied.

CAUSE

The problem only occurs if the user does not have full administrative rights to the computer.

RESOLUTION

Windows NT 4 Service Pack 6a has been released to fix this problem. A hotfix is available to update SP6 systems to SP6a. For more information, please click the article link below to view the article in the Microsoft Knowledge Base:

246009 Windows NT 4.0 Service Pack 6a Available

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file. The English-language version of this fix should have the following file attributes or later:
   Date        Time     Size       File name   Platform
   -----------------------------------------------------
   11/11/1999  05:18p    66,352    Afd.sys     x86
   11/11/1999  05:23p   115,184    Afd.sys     Alpha
				

STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 Service Pack 6.

Modification Type:MinorLast Reviewed:1/24/2006
Keywords:kbHotfixServer kbQFE kbbug kbfix KB245678