DHCP Reservations Cannot Be Removed, Other Settings Inaccessible, No Backup DB (245036)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0

This article was previously published under Q245036

SYMPTOMS

When you attempt to delete reservations in DHCP (Dynamic Host Configuration Protocol) Manager, the option for deleting reservations and related settings may not be available. The DHCP service may not start. Also, when you attempt to use the Jetpack.exe utility to compress the DHCP database, you may not be able to do so, and Event Viewer may record the following event:
Event ID 1010: The DHCP server encountered the following error when cleaning up the user database: The system cannot find the file specified.

CAUSE

This behavior can occur if you install an earlier version of the Dhcp.mdb file over a later version, or if DHCP scope settings in DHCP Manager are corrupted.

RESOLUTION

To resolve this issue, if you have a backup copy of the Dhcp.mdb file, replace the damaged Dhcp.mdb file with the backup copy; if you do not have a backup copy of the file, re-create the database in Microsoft Windows NT Server 4.0.

To replace the damaged Dhcp.mdb file with the backup copy, follow these steps:

  1. Locate the backup copy in the %SystemRoot%\System32\Dhcp\Backup\Jet\New folder.
  2. Move the backup copy to the %SystemRoot%\System32\Dhcp folder to replace the damaged Dhcp.mdb file.
To re-create the database in Microsoft Windows NT Server 4.0, follow these steps:

  1. If possible, write down all of the scope settings (including reservations).
  2. Stop the DHCP service if it is running.
  3. Delete the Dhcp.mdb file from the %SystemRoot%\System32\Dhcp folder.

    NOTE: When you delete the Dhcp.mdb file, any reservation and lease information is lost. However, when you restart the DHCP service, the Dhcp.mdb file is re-created. The registry restores certain scope settings, but you must manually re-create reservations.
  4. Start the DHCP service.
  5. Reconcile the database:
    1. Start DHCP Manager.
    2. Double-click the DHCP server, and then click the correct scope.
    3. On the Scope menu, click Active Leases.
    4. Click Reconcile, and then click OK.
  6. Under Server Properties, set the value in the Conflict Detection box to a value higher than the default value (3), and then click OK.
  7. Monitor the lease database. If you find any bad addresses, follow these steps:
    1. Delete the bad address entries.
    2. Reconcile the database.
    3. To test DHCP, on a client computer, type ipconfig /release at a command prompt, and then press ENTER.
    4. Type ipconfig /renew at the command prompt, and then press ENTER.

Modification Type:MajorLast Reviewed:8/27/2002
Keywords:kbprb KB245036