Dr. Watson Error in CSRSS on Terminal Server Computer (244927)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition

This article was previously published under Q244927

SYMPTOMS

When you start a connection from a client, a Dr. Watson error in CSRSS may be generated on the Terminal Server computer. This causes a single session to not connect.

CAUSE

This behavior occurs because of an initialization timing issue in CSRSS during ClientThreadSetup. The first thread performs some of the initialization, but other threads may enter the code even though the first thread has not yet completed initialization.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

152734 How to Obtain the Latest Windows NT 4.0 Service Pack


STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition.

This problem was first corrected in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 6.

Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kb3rdparty kbbug kbenv kbfix kbQFE KB244927