Nonpaged Pool Memory Leak May Occur Attempting to Read Partition Table (244509)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition SP4
  • Microsoft Windows NT Server 4.0 Terminal Server Edition SP5
  • Microsoft Windows NT Server 4.0 Terminal Server Edition SP6
  • Microsoft Cluster Server
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server 4.0 SP1
  • Microsoft Windows NT Server 4.0 SP2
  • Microsoft Windows NT Server 4.0 SP3
  • Microsoft Windows NT Server 4.0 SP4
  • Microsoft Windows NT Server 4.0 SP5
  • Microsoft Windows NT Server 4.0 SP6
  • Microsoft Windows NT Server, Enterprise Edition 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP4
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP5
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP6
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Workstation 4.0 SP1
  • Microsoft Windows NT Workstation 4.0 SP2
  • Microsoft Windows NT Workstation 4.0 SP3
  • Microsoft Windows NT Workstation 4.0 SP4
  • Microsoft Windows NT Workstation 4.0 SP5
  • Microsoft Windows NT Workstation 4.0 SP6

This article was previously published under Q244509

SYMPTOMS

In Windows NT 4.0, a nonpaged pool memory leak may occur when functions like IoReadPartitionTable() or DeviceIoControl() attempt to read a partition table. The Microsoft Developer Network explains these functions at:

CAUSE

This problem occurs because memory allocated when reading the partition table may not be freed in the event that an error, such as STATUS_DEVICE_BUSY, is returned.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of the Windows NT Server and Windows NT Workstation fix should have the following file attributes or later:
   Date      Time                 Size    File name     Platform
   -------------------------------------------------------------
   10/28/1999  07:10p           1,405,248 Ntkrnlmp.exe  Alpha
   10/28/1999  07:10p           1,376,896 Ntoskrnl.exe  Alpha

   10/28/1999  07:13p             952,192 Ntkrnlmp.exe  i386
   10/28/1999  07:12p             932,032 Ntoskrnl.exe  i386
				

STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0.


Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kbenv kbfix KB244509