Starting Internet Explorer Opens an MS-DOS Command Prompt Window (244460)



The information in this article applies to:

  • Microsoft Internet Explorer 5.5 for Windows NT 4.0
  • Microsoft Internet Explorer 5.01 for Windows NT 4.0
  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 2
  • Microsoft Internet Explorer 4.0 for Windows NT 4.0
  • Microsoft Internet Explorer 5.5 for Windows 98
  • Microsoft Internet Explorer 5.01 for Windows 98
  • Microsoft Internet Explorer 5.0 for Windows 98
  • Microsoft Internet Explorer 4.01 for Windows 98 SP 2
  • Microsoft Internet Explorer 5.5 for Windows 95
  • Microsoft Internet Explorer 5.01 for Windows 95
  • Microsoft Internet Explorer 5.0 for Windows 95
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 1
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 2
  • Microsoft Internet Explorer 4.0 for Windows 95

This article was previously published under Q244460
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

After you install Internet Explorer and attempt to start the program, an MS-DOS command prompt window is opened instead of the Internet Explorer browser window.

CAUSE

This behavior occurs if the Internet Connection Wizard (ICW) is not installed properly during Internet Explorer Setup.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue, use the appropriate method.

Method 1

Remove the installed components key for the ICW component and reinstall Internet Explorer:
  1. Click Start, click Run, and type regedit, and then click OK.
  2. Locate the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{5A8D6EE0-3E18-11D0-821E-444553540000}

  3. Right-click the Installed Components key, and then click Delete.
  4. On the Registry menu, click Exit.
  5. Reinstall Internet Explorer.

Method 2

Manually install Internet Connection Wizard:
  1. Click Start, click Run, and type regedit, and then click OK.
  2. Locate the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{5A8D6EE0-3E18-11D0-821E-444553540000}

  3. Right-click the Installed Components key, and then click Delete.
  4. On the Registry menu, click Exit.
  5. In Windows Explorer, click File, point to New, click Folder, and then create a temporary folder on drive C called ICW.
  6. Extract the contents of the Icw95.cab file into the newly created ICW folder using the Extract command-line tool (the Icw95.cab file is located in the folder where you downloaded Internet Explorer 4.0x). For additional information about using the Extract tool, click the article number below to view the article in the Microsoft Knowledge Base:

    129605 How to Extract Original Compressed Windows Files

  7. Click Start, click Run, and then type the following command:

    rundll32 advpack.dll,LaunchINFSection c:\icw\icw95.inf,defaultinstall

    NOTE: The .cab and .inf files in Internet Explorer 4.0x are named Icw95.cab and Icw95.inf. In Microsoft Internet Explorer 5.x, the file names are Icw.cab and Icw.inf. This command line needs to be modified accordingly, depending on the version of Internet Explorer.

Modification Type:MajorLast Reviewed:12/8/2003
Keywords:kbenv kbprb kbsetup KB244460