RIS Client May Stop Responding in Text-Mode Setup on a Network Without NetBIOS (243500)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

This article was previously published under Q243500

SYMPTOMS

When you are installing Windows 2000 from a Windows 2000-based Remote Installation Service (RIS) server using an RIS Pre-Boot Execution Environment (PXE) client, the installation may stop responding (hang) during the Text-mode portion of Setup if the following conditions are true:
  • The client becomes temporarily disconnected from the network.
  • The network does not use NetBIOS.
In addition, the client stops responding when loading kernel (at the textmode screen "Starting Windows 2000"). This symptom can occur if the following conditions are met:
  • The network and/or server has NetBIOS disabled.
  • The server is running Windows 2000 Service Pack 2.

CAUSE

The first symptom can occur if an RIS PXE client is disconnected from the network at any time during the Text-mode portion of Windows 2000 Setup; the client cannot reconnect to the server unless NetBIOS is enabled on the network.

This behavior occurs because the PXE client stores the RIS server's IP address in its memory cache. If the client is disconnected, the IP cache is automatically flushed. When the client is reconnected to the network, it attempts to find the server using NetBIOS name resolution and continues to try until it finds the RIS server. If NetBIOS is not active on the network, the client may stop responding.

To work around this behavior, reset the client to restart the Setup process by using the Client Installation Wizard. On a network that uses NetBIOS, this is not an issue; the client automatically reconnects when the NetBIOS name is resolved and then continues with Setup.

The second symptom (in which the client stops responding)can be resolved by downloading the fix provided by Microsoft in the "Resolution" section of this article.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

The English version of this fix should have the following file attributes orlater:
   Date         Time   Version        Size     File name 
   -------------------------------------------------------
   05-Sep-2001  17:33  5.0.2195.4296  143,024  Netbt.sys
				

NOTE: This update only resolves the issue where the client stops responding while loading the kernel (at the textmode screen " Starting Windows 2000"). Any client that becomes disconnected from the network when the RIS server is not running NetBIOS must be restarted.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.

Modification Type:MinorLast Reviewed:9/22/2005
Keywords:kbHotfixServer kbQFE kbbug kbenv kbfix kbnetwork kbsetup kbWin2000sp3fix KB243500