XADM: Replication Doesn't Work; Event 1171 with Parameters 9 and 111 (243438)
The information in this article applies to:
- Microsoft Exchange Server 5.5
This article was previously published under Q243438 SYMPTOMS
Exchange Server intersite directory replication does not work properly, and the following events are logged in the application event log on an Exchange Server replication bridgehead server:
Event Type: Error
Event Source: MSExchangeDS
Event Category: Replication
Event ID: 1224
Description:
Fatal replication error (internal ID 303025f). Parameter(s)
2615834 941779. Contact Microsoft Technical Support for assistance.
Event Type: Error
Event Source: MSExchangeDS
Event Category: Internal Processing
Event ID: 1171
Description:
Exception e0010002 has occurred with parameters 9 and 111
(internal ID 3030260). Contact Microsoft Technical Support
for assistance.
CAUSE
The Exchange Server computer that is receiving these events has one or more objects in its directory with USN-Changed attribute values greater than the latest USN-Changed attribute value given to an object in the directory.
RESOLUTION
To resolve this problem, you can use command-line directory export, search for all objects with a USN-Changed attribute value greater than the latest change made in the directory, and then modify those objects. WARNING: If you use the raw mode of the Exchange Server Administrator program ( admin /r) incorrectly, serious problems may occur that may require you to reinstall Microsoft Windows NT Server, Microsoft Exchange Server, or both. Microsoft cannot guarantee that problems that result from using raw mode incorrectly can be solved. Use raw mode at your own risk.
To find the highest expected USN-Changed attribute value on the Exchange Server computer:
- Start the Microsoft Exchange Server Administrator program in raw mode by typing the following at a command prompt:
- Open the properties of a mailbox or custom recipient.
- Make a change to that object (such as the city or phone number), and click OK.
- Open the raw properties of that same object and look at the value for the USN-Changed attribute. Make a note of this value for a future step.
To find the directory objects that have incorrect USN-Changed attribute values, run a command-line directory export, and analyze the resulting export file:
- Create a plain text file with the following text, and save it in the Exchsrvr\Bin folder with the file name Usn.csv:
Obj-Class,Directory Name,Obj-Dist-Name,Is-Deleted,USN-Changed
- Create a plain text file with the following text, and save it in the Exchsrvr\Bin folder with the filename Export.ini:
[Export]
DirectoryService=Your_Exchange_Server_Name
Basepoint=/o=Your_Exchange_Organization_Name
Subcontainers=Yes
ExportObject=All
RawMode=yes
HiddenObjects=yes
InformationLevel=Full
- Open a command prompt in the Exchsrvr\Bin folder, and run the following command:
admin /e usn.csv /o export.ini - After the export is finished, open the Usn.csv file in a spreadsheet or in database software, and sort the information based on the USN-Changed attribute values. You need to correct the objects in the spreadsheet that have a higher USN-Changed attribute value than the highest USN-Changed attribute value found in step 4 of the first procedure.
To correct the USN-Changed attribute values of these problem objects, start the Microsoft Exchange Server Administrator program, and make changes to the objects whose USN-Changed attribute value is too high. These objects will be assigned new USN-Changed attribute values that are correct for the server.
After you make the modifications to the problem objects in the Exchange Server directory, replication should start working again on its own.
Modification Type: | Minor | Last Reviewed: | 4/21/2005 |
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Keywords: | kbprb KB243438 |
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