PRB: Edit Option in Internet Explorer Does Not Show Proper Page (243356)



The information in this article applies to:

  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 3.02 for Windows NT 4.0
  • Microsoft Internet Explorer 5.0 for Windows 98
  • Microsoft FrontPage 2000

This article was previously published under Q243356

SYMPTOMS

When browsing to certain sites, you may find that when you select the Edit button in Internet Explorer, the page displayed in the FrontPage Editor is not the same page you were viewing in your browser.

CAUSE

This behavior occurs because when the FrontPage Editor is started, a new process begins that requests the URL you are viewing in your browser. Because the request is run from the FrontPage process and not the Internet Explorer process, the request can potentially look different to the Web server that services the request. The Web server may respond with different content than what you are viewing in your browser.

For example, if the server is using a temporary HTTP cookie to maintain user state on the server, the temporary cookie is not sent by the new FrontPage process, because temporary cookies are not shared between processes. Therefore, the server may treat the request differently than the request from Internet Explorer, and it may return a different page to FrontPage Editor.

MORE INFORMATION

You may also notice that you are prompted to enter your authentication information again from FrontPage Editor. This is because authentication information, like temporary cookies, is not shared between processes.

Modification Type:MajorLast Reviewed:11/24/2003
Keywords:kbprb KB243356