Services for Macintosh May Cause a Problem When FastIoUnlockSingle() Returns FALSE (242896)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server 4.0 SP4
  • Microsoft Windows NT Server 4.0 SP5
  • Microsoft Windows NT Server 4.0 SP6
  • Microsoft Windows NT Server 4.0 SP6a
  • Microsoft Windows NT Server, Enterprise Edition 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP4
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP5
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP6
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP6a

This article was previously published under Q242896

SYMPTOMS

Services for Macintosh (SFM) may cause the computer to stop responding (hang) when FastIoUnlockSingle (a FastIO dispatch routine) returns FALSE. This corrupts the kernel memory and is sufficient to cause the computer to hang within a small number of input/output (I/O) operations. File systems and file system filter drivers sometimes need to prevent the FastIO path, usually because outstanding synchronization (for example, OpLocks and ByteRange locks) does not allow a simple pass-through of the operation to FsRtl or Cache Manager. Because the majority of FastIO routines are Boolean functions, the FastIO path can be disabled a FALSE response, thereby forcing an operation to take the Input/Output Request Packets (IRP) path instead.

Depending on how often a driver must disable FastIoUnlockSingle and the pattern of unlocks on a given computer, the problem may occur very frequently or very rarely.

CAUSE

Because SFM attempts to free the IRP twice in the completion routine and once in the routine that allocated the IRP, it causes Kernel-mode memory corruption. This in turn causes the computer to hang with a STOP error message.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English-language version of this fix should have the following file attributes or later:
   Date      Time                 Size     File name     Platform
   --------------------------------------------------------------
   09/29/99  07:49 PM             134,416  Sfmsrv.sys    Intel
   09/29/99  07:48 PM             241,744  Sfmsrv.sys    Alpha
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix KB242896