"Setup Was Unable to Open Information File" Connecting to SBS (241882)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.0
  • Microsoft BackOffice Small Business Server 4.5

This article was previously published under Q241882

SYMPTOMS

When you log on to a BackOffice Small Business Server (SBS) network from a client computer, you may receive the following message:
Setup is initializing,please wait...
The following error message is then displayed:
Setup was unable to open information file \\Servername\Clients\Response\Clientcomputername\Clioc.inf. Contact your system administrator. The specific error code is 0x2 at line 16844856
When you click OK, you you receive the following error message:
Setup was unable to load the master information file.
When you click OK, you you receive the following error message:
The application could not be initialized.
When you click OK, you are logged on, but no client programs are installed on the client computer.

CAUSE

This behavior occurs when the Setup program is unable to access the folder for this client computer in the Response folder on the server. Every client computer that connects to the Small Business Server must have a folder with the same name as the client computer in the Response folder to successfully run the user's logon script.

This issue can also occur if the permissions have been changed on the Clients directory on the SBS 4.5 server to deny access to domain users.

RESOLUTION

To resolve this issue:
  1. Using Windows Explorer, open the C:\SmallBusiness\Clients\Response folder.
  2. Create a new folder in this folder with the appropriate computer name.
  3. Copy the contents of an existing client folder into this new folder.
  4. Log off and then log back on to the client computer.
NOTE: Make sure that no file named Installed exists in the new client folder after you copy the contents from an existing folder. If this file exists, SBS skips the installation of the client programs.

Also note that the Clioc.inf file contains the information that specifies which programs are copied and installed. If you copy an existing Clioc.inf file to the new folder, the same programs are copied and installed. To remove certain programs, edit the Clioc.inf file in the new folder and remove the .inf files that point to the specific programs you do not want to install from the "Components.x86" and "Components.w95" sections.

MORE INFORMATION

This problem can also occur when you are using a Terminal Server client because the Terminal Server client must have a folder in the Response folder also.


Modification Type:MajorLast Reviewed:10/30/2003
Keywords:kbenv kberrmsg kbprb kbsetup KB241882