Computer May Stop Responding or Experience Slow Download Times with Universal Serial Bus Modem (240947)



The information in this article applies to:

  • Microsoft Windows 98 Second Edition

This article was previously published under Q240947

SYMPTOMS

When you perform large file transfers over Universal Serial Bus (USB) modems using communications device class (CDC) compliant USB drivers in Windows 98 Second Edition, throughput speed may decrease. In addition, the computer may stop responding (hang) after a few minutes.

CAUSE

Interactions between the virtual communications device (Vcomm.vxd) and the Windows Driver Model (WDM) modem port driver (Ccport.sys) can cause the system to abandon successive timer events. The computer may hang when it attempts to handle these events.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date         Time   Version      Size    File name
   -----------------------------------------------------
   04-Oct-1999  12:21  4.10.0.2223  37,680  Ccport.sys
   04-Oct-1999  12:33  4.10.0.2223   7,789  Wdmmdmld.vxd
				

STATUS

Microsoft has confirmed that this is a problem in Windows 98 Second Edition.

This problem is resolved in Windows Millennium Edition (Me).

MORE INFORMATION

This issue is known to affect the following products:
  • 3Com OfficeConnect 56K Business Modem
  • Compaq 56K USB Fax Modem
  • 3Com ISDN TA Terminal Adapter
You may also be able to resolve this issue by obtaining an updated driver for your 3Com modem from the following 3Com Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

For additional information about Windows 98 and Windows 98 Second Edition hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

206071 General Information About Windows 98 and Windows 98 Second Edition Hotfixes


Modification Type:MinorLast Reviewed:10/18/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB240947