XCLN: Local Free and Busy Cache Not Updated If Viewed Remotely When Using Resource AutoAccept Scripts (240233)



The information in this article applies to:

  • Microsoft Exchange Server 5.5
  • Microsoft Exchange Server 5.5 SP2
  • Microsoft Outlook 97 8.03
  • Microsoft Outlook 97 8.04
  • Microsoft Outlook 98
  • Microsoft Outlook 2000

This article was previously published under Q240233

SYMPTOMS

If you use the updated AutoAccept Event script, when you access the resource calendar (on the File menu, click Open, and then click Other User's Folder) with Reviewer permission, the following error message is displayed:
Can't open this item. Unable to open the free/busy information.
Also, dates on which meetings are scheduled may not be bold, and the AutoAccept script may not decline conflicting meetings.

CAUSE

You do not have full control permissions to update the locally cached copy of free and busy information for the resource. The following process occurs:
  1. The free and busy information is updated on the server.
  2. The locally cached copy of the free and busy information is deleted.
  3. The server attempts to provide a complete copy of the free and busy information to the client.

    NOTE: If the client that you currently use to log on to the server does not have full control permissions, the locally cached copy is not updated.
  4. You experience the problems described in the "Symptoms" section of this article.

WORKAROUND

You can use one of the following methods to work around this problem:

Workaround 1

  1. Set up one Windows NT account that has full permissions for all of the resource mailboxes that use the AutoAccept script.
  2. Log on to each resource mailbox once, and set each resource mailbox to update the free and busy information on the server every minute:

    1. On the Tools menu, click Options.
    2. Click Calendar Options, and then click Free/Busy Options.
    3. In the Update free/busy information on the server every box, type 1.
    Then log off from the resource mailbox.
  3. At a client computer, log on using the Windows NT account that you created that has full permissions for all of the resource mailboxes.
  4. Start Outlook and log on to one of the resource mailboxes. On the File menu, click Open, and then click Other User's Folder to open every other resource mailbox, and then leave them open.

Workaround 2

Log on to the server using the resource mailbox, and then open Outlook using the /CleanFreeBusy switch.

Workaround 3

This workaround requires a pure Outlook 2000 environment. Deploy Outlook 2000, and then follow the instructions in the following Microsoft Knowledge Base article:

192877 OL2000: (CW) Direct Offline Booking of Resources

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

179303 XADM: Reducing Event Service Firing Delays


Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbbug kbnofix KB240233