XIMS: Exchange Server Internet Mail Service Stops Responding with a Particular Message (239816)



The information in this article applies to:

  • Microsoft Exchange Server 5.5
  • Microsoft Exchange Server 5.5 SP1
  • Microsoft Exchange Server 5.5 SP2

This article was previously published under Q239816

SYMPTOMS

When a message is sent to a domain whose mail servers are currently unavailable and the message has a subject that includes the substring "%s", the Internet Mail Service may stop responding (crashes) if the SMTP protocol logging is set to Maximum.

CAUSE

The crash occurs when the "499 No routing hosts are reachable" error is written into the SMTP log file. The original string to be written is:

"7/5/99 9:31:55 PM : 499 No routing hosts are reachable for test.com. Message subject: ""RE:33%s5%s99"". Rescheduling delivery for later."

The Internet Mail Service fails to determine whether "%s" is a substring or a specification of a substring.

RESOLUTION

To resolve this problem, obtain the latest service pack for Exchange Server 5.5. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

191014 XGEN: How to Obtain the latest Exchange Server 5.5 Service Pack

WORKAROUND

Disable SMTP protocol logging.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Exchange Server 5.5 Service Pack 4.

Modification Type:MajorLast Reviewed:10/2/2003
Keywords:kbbug kbExchange550preSP4fix kbExchange550sp4Fix kbfix kbQFE KB239816